Change SRSS report DP from regular to TempDB

Hi guys.

I have an issue with changing report DP type from regular (ex. SrsReportDataProviderPreProcess ) to TempDB ( SrsReportDataProviderPreProcessTempDB). I have an LedgerTransStatement report, which originally was TempDB report, but someone from my team changed it while developing some modifications. Now I can’t change it to TempDB, because I’m getting errors:

Error executing code: Wrong argument types in variable assignment.

Stack trace:

(S)\Classes\SrsReportDataProviderPreProcess\parmUserConnection - line 3
(S)\Classes\SrsReportRunRdpPreProcessStrategy\execute - line 24
(S)\Classes\SrsReportRunRdpPreProcessStrategyTempDB\execute - line 6
(S)\Classes\SrsReportRunRdpPreProcessService\executeWithContract - line 82
(S)\Classes\SrsReportRunRdpPreProcessService\executeRDLClasses - line 38
(C)\Classes\SrsReportRunService\preRunReport - line 26
(C)\Classes\SrsReportRunImpl\preRunReport - line 12
(C)\Classes\SrsReportRunController\runReport - line 45
(C)\Classes\SrsReportRunController\run - line 6
(C)\Classes\SysOperationController\startOperation - line 10
(C)\Classes\SrsReportRunController\startOperation - line 12
(C)\Classes\LedgerTransStatementController\main - line 8

Here I have regular assignment, which should work, but it gives this strange error. Note, that it does not using “TempDB” version of the class. I have no idea how to fix it. I have tried small CIL compilation, but it didn’t worked.

Here’s the code, where i’m getting errors (3rd line)

It seems that your code isn’t correctly compiled. Please try to recompile the whole class hierarchy, i.e. right-click SRSReportDataProviderBase class and choose Add-Ins > Compile forward.

It looks like that only full CIL compilation and AOS restart helps for this problem. Thanks anyway :wink: Compile forward isn’t enough.

Sure, if you run it in CIL, you have to compile CIL too.