Cannot publish extension in Business Central CU01 NA


when i tried to publish the extension in Business Central CU01 NA in the ouput tab it is saying that package is created and in the Debug console it is not saying the Package is created and in the BC windows client in the Extension page it didn’t created any extension package file

Thanks in Advance.

A bit more information please. Exactly what message do you get and which version of AL and VSCode?

And now you may say it didn’t show you more. And depending on the version of VSCode. So any questions regarding AL developer, please say AL and VSCode version.

In the most recent builds of VSCode there is a bug or something. It means that even if your package was build, then it will only show the debug output, when it actually starts debugging.

If that happens, try to press F6 instead of F5. That will build and publish, but not debug, with the result that you get any error messages in the output window instead.

Hello Erik,

Image 1 is Visual Studio code version and Image 2 is information about the app. I have tried F6 and F5, still not published the extension it is saying package created.



And when you press F6, exactly what does it say in the output window in VSCode, when it says that it created the package?

Hey Erik,

I found the solution its seems like there is some issue in VS Code I have Downgraded from 1.29.1 to 1.27.2 and now its working. Extension got published.


Yes, that was exactly what I wrote to you above. The issue is that VSCode 1.29.0 and 1.29.1 does not show any errors or messages in the debug window when you press F5, unless it succeed. F6 in 1.29.0 and 1.29.1 would also have worked.