Cannot deploy ssrs report AX 2012.

Hi Everybody!

I have a problem to deploy ssrs report (modified standard report), the error is:

I have all the rights. And i tried to check SQL server reporting services, i cannot see the “sit setting”.

what is missing?


Try to Run AX as administrator and t deploy the SSRS report.
If the same error persist try to deploy using Following steps
Click Start > Administrative Tools.
Right-click the Microsoft Dynamics AX 2012 Management Shell option.
Click Run as administrator.
use the below command to deploy

Publish-AXReport -ReportName yourreportname

Hi $@n$h€46 , thx for your reply, i have followed your method, i got the same error. I have disabled the UAC. It seems that i still miss some rights, but could not find it out, which one?

Use this command to deploy report without security check.
Publish-AXReport -ReportName yourreportname -skipReportServerAdminCheck

Also please do not forget to start the Management shell as an Administrator.

Hi Lalit,

Thanks! I have tired, with no luck! I got this:


You can also try this link to deploy the ssrs report.…/

Are you an administrator on the server where your reporting services are installed? If you are not & if it is possible, add your user in the administrative group.

Hi Rosa,

Did you try to right click the MS Dynamics Icon then run as Administrator, Then deploy your specific SSRS Report in AOS Window.? But before you deploy it, Clear all caches first.