Business Central database stuck in OperationalDataUpgradePending state

Any way to push the state of the database back and forth?

I have just upgraded a NAV2018 database to Business Central (14.0.32600.0) but for some reason the database has reverted to OperationalDataUpgradePending…
The upgrade itself seemed to go as it should. The synchronisation went good, the dataupgrade completed. I restarted, and began adding the danish extenions, but then something happened when installing the; the system stuck and now I am unable to put in any more extensions, or even download symbols to VS Code.
The system itself seems to be running. I can start the client, and even see which extensions are published and which are installed. But I can’t put my extensions in.

When trying to install the OIOUBL I get an error “Install-NAVApp : Cannot install apps due to the state of the tenant: OperationalDataUpgradePending.”
Then I tried to use Start-NavDataUpgrade, but get “Start-NavDataUpgrade : Cannot start the data upgrade process because tenant version is already the latest application version the tenant database supports (14.0.21441.0). Call Sync-NAVTenant”

I then tried to Sync-NAVTenant but that doesn’t seem to do anything. At least I still get the same error when retrying data upgrade.

I’ve tried messing around with Set-NAVApplication and forcing different versions to see if that might do something. But so far without any luck

Does anybody have any suggestions on how I can proceed? I really don’t want to start the entire upgrade process again, and just hope that I don’t hit the same problem again…

When trying to download symbols from VS Code I get “The request for path /BC140/dev/packages?publisher=Microsoft&appName=System&versionText= failed with code ServiceUnavailable. Reason: The tenant ‘default’ is not accessible.”

I had a similar experience this week. I was trying to install an extension build for the W1 version in a DK location. I didn’t get the exact same message, but it clearly showed me that it’s important to have the same localization.

You only mentioned:

So if that’s not the DK location, and the OIOUBL has been build for the Danish version, then it will not work on a W1 or any other localizations without recompiling for that specific version.

Also did you try to connect to the upgraded database, before starting the app publishing (assuming you DID publish the app before using Install-NAVApp)? Make sure that you can connect to it and that it otherwise is functional, before proceeding to app publish/install.

If this didn’t help, them my guess is that something went wrong in your upgrade process.

Localization is danish; both NAV2018 and Business Central. I cannot remember if I connected a client to the database before starting the publishing parts, but both test and system apps were published first as well as generatesymbols and a restart of the service. Publish, synchronize and install is fixed procedure, and it went as it should with both FIK and VATreports, but OIOUBL stuck on install.

I was able to get it running again by forcing the version back to 14.0.21441.0 and then increment the version. That allowed me to synchronize and upgrade (again) and after that publish and install my own extensions.

OIOUBL however will still not install. When running the client and looking at which extensions are present it lists our own, and the selected ones from Microsoft as installed and OIOUBL and published. If I try to install the OIOUBL (tried both with powershell and from withiin the client) the whoe system will hang.
Net step will be to unpublish it and recompile the extension (and fix the stringlenght of the description in the export)