BC publishing issue

Hello All,

One more new thing faced today. I created new project and trying to publish HelloWorld but getting bellow window.

and browser looks like this

if I try to connect directly to Sandbox through browser its connecting.

What is this issue? I clear history, restarted system.

Web%20Request%20Helper.dal window opens in VS Code.

can someone tell

what is the issue,reason and how to resolve it.

Thanks in advance.


I think you have published (.al files/ objects) earlier also or is it the first time that you are publishing it?

Is there any change in launch.json file after last successful launch?

Are you able to see the changes of HelloWorld code if you open it directly from browser?

Is your HelloWorld program calling any webservice?

I have created new project, then connected to Cloud sandbox and tried to publish Helloworld file but I got error that: 'runtime is 2.2 in app.json file it should br 2.1 or less. as shown in below screen shot. so changed it to 2.1.

Also I tried to check runtime in app.json files in my previous removed projects. for that I opened removed project’s json files in notepad format. but by mistake it was ticked : always use this app to open .json file so now in my current project app.json file looking in notepad format.


Did the previous project also work after changing ‘runtime’?

By the way:

An error will be thrown when you publish an extension with a higher runtime version than the one that platform supports. For example, if you set the runtime value to 2.0, you get the following error message:

The runtime version of the extension package is currently set to ‘2.0’. The runtime version must be set to ‘1.0’ or earlier in the app.json file in order to install the extension package on this platform.

For previous projects i need not to do any changes in run time and any other parameters. I am using standard parameters till now. As I deployed one time on LIVE server after that I changed Version.

Again in new project I changed the parameters runtime = 2.1(by default it came 2,2) and version = For some time it works and suddenly Trial Balance Mgt codeunit open in VS Code and on browser message continues : its working. So I closed Trial Balance Mgt codeunit(1318) from VS Code and refresh the browser but nothing comes so again I publish helloworld file. After that again Web Request Helper codeunit opens in VS Code. and it continues. and unable to do anything.

Why this Web Request Helper codeunit(1299) opening again and again as I publish helloworld file?