AXadmin password change -SSRS not running


Today changed the password of AXadmin user.

JFYI, the windows adminstrator user is the same user for AX also.

I opened windows services and changed with new password for the services which was using axadmin user.

Restarted AOS, SQLServer, SQL Reporting Services.

AX opened, but when I run the SSRS its not working.

I even opened SQL Server Reportiong Services configuration manager. Went thru the wizards again.

Any step I missed out ?


Hi Mazherullah

A couple of things:

  • Always use the dedicated tools for SQL Server when making modifications on service accounts. This means using the SQL Server Configuration Manager for mostly all SQL Server related services, but perhaps specifically use the SQL Server Reporting Services Manager for modifications related to SSRS in particular. It is not advisable to use the regular Windows Services, as there may be additional steps covered when using the dedicated SQL Server tools which are NOT covered when using plain Windows Services. I don’t have any details, but it is a recommendation, just to be safe you don’t accidentally miss out when not using the tools.
  • The SSRS Service itself should run under the same account as the Dynamics AX Business Connector. This is part of the installation specification for Dynamics AX. I don’t know how you’ve set this up, but it sounds like you run everything under the same user account (AXadmin?), but just making sure you know it is vitally important the SSRS Service that hosts the AX Reports run under the Business Connector Account.

I have previously blogged about the setup of SSRS for multiple instances here:…/setting-up-multiple-instances-of-report.html

You may still find this post interesting even if you only setup one SSRS instance.

Hope this helps.

Dear Tommy,

Thanks for your reply.

The Technical person who installed used axadmin user for everything.

I deleted the dynamicsax report folder and redeployed the reports. It worked fine in the server.
But from client pc when I run the report it shows the following error :

Assembly containing type Microsoft.Dynamics.AX.Frameworks.Controls.ReportViewer.ReportAdapterFactory is not referenced.

Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

Did you encountered this before .

The URL you shared, i think article has been moved.


hi , you need to give the same user name and password in the exceution account in the report manger url

Yea, I see the link got broken somehow. The link gets broken by the forum itself, if you look at the url after clicking it. Since I can’t edit my post, I can only try again:…/setting-up-multiple-instances-of-report.html
If it is still broken, I’ll report it as a bug on this forum)

This link opens. Thanks. Can u share your experience reg. my updated msg. the error msg. from client pcs. But in server its working. Will try to test Mr. srikanth solution