AX2012 RTM setup fails

Hi there,

We have AX2012 RTM already installed and (UAT,TEST) and (PROD), I’m trying to run the setup on TEST environment to install web services on IIS, however the setup is getting every time when I run it, I get the following error (No info in the event viwer) The same installation with the same setup files works fine on UAT environment, I’m sure that there is no problem with the AX installation files, there must be something wrong on the server. any one have come across such issue? Can some one help me out on how to proceed trouble shooting such problems. Any help regarding this is highly appriciated.

Problem Event Name: CLR20r3
Problem Signature 01: axsetup.exe
Problem Signature 02:
Problem Signature 03: 50b71aa1
Problem Signature 04: Microsoft.Dynamics.MsiManagedLib
Problem Signature 05:
Problem Signature 06: 4e0987da
Problem Signature 07: 18
Problem Signature 08: 34
Problem Signature 09: T0EN5SRQCCK32F2BZAUL3SCJ3WGV0G42
OS Version: 6.1.7601.
Locale ID: 1031

With kind regards,


At which step do you get the error? Please also look into the log file, unless it fails even before starting the installation.

Hi Martin, Thank you for your reply.

The problem is setup fails at very begining. The moment I click on Setup.exe the “welcome to Setup for MS dynamics AX2012” screen appears on which there are options to Prepare and Install, under Prepare we have option to Validate System requirements, when click on this i see the next options to select on and can validate the system requirements without any issues, however the setup fails the moment I click on “Microsoft Dynamics AX components under” install section.

I get the same above message every time, there is no log create, because the process is failing in the very begining, also there are no event log created. getting very difficult on how to troubleshoot this issue, Is there any alternative way we can dig this into next level? Many thanks for your reply again.

First of all, try running the installer with elevated permissions (right-click > Run as administrator).
If you run the installer from a network location, copy it locally and try it again.

Hi Martil, I have tried already both options what you mentioned, The stup files are executed locally not from network location, and also the setup.exe has been executed by selecting run as Administrator. Any other suggestions?

What’s your operation system and versions of .NET?

Windows Server 2008 R2 with Microsoft .Net Framework 4 (Version = 4.0.30319).
As mentioned earlier on UAT server we have same specs, same installation files and it works there.
I also tried restarting the TEST server, but no luck :frowning:

I can not troubleshoot this further because there are no logs no events. There is nothing to which I can refer and proceed.

You collect a memory dump and do post-mortem analysis to find out more, but it’s not much fun. I prefer throwing such things at Microsoft - their support stuff are much more experienced with these things.

Prefer rebuilding the System from scratch since it is at the beginning stage, I wouldn’t compromise/suggest to use such system with a fix. Sometime it is minor issue we discover it later, But there goes lot of time in diagnosing with the chase. Better save a image and pursue it separately.

If you have completed the “Pre-requisite Validation”, should have noticed the logs under the below folder for specific date & time.
“C:\Program Files\Microsoft Dynamics AX\60\Setup Logs”

Can you review those files DynamicsSetupLog.txt, Prerequisite Report.html, SetupPrepLog.txt, and Components64 Log.txt , probably that should help.