AX 2012 Import issue.


I am importing USR model file from one environment to VAR layer in another environment using AXUTIL import command.

While importing to the VAR layer I am getting the below error.

“ERROR: The model file MyModel.axmodel is from a newer version of Microsoft Dynamics AX (version 6.0.1108.670) and cannot be installed.”

I have done the below analysis.

  1. Have checked the version number, Kernel number in both envi and it is same.
  2. Have the version number of AXUTIL.exe both are same.
  3. Have tried to import in a dummy server in USR layer, imported successfully.


  1. Is it possible to move from one layer to another.
  2. As the versions are same why I am getting the below error.

Kindly guide me.


On a single server installation type you can have multiple Axutil.exe, for example you can locate it in: C:\Program Files\Microsoft Dynamics AX\60\ManagementUtilities C:\Program Files\Microsoft Dynamics AX\60\Server\MicrosoftDynamicsAX\bin Did you confirm you all the axutil.exe have the same version?

Yes of course, I have double checked that and having same version. But one important thing is it possible to move a USR model from DEV 1 to VAR layer in DEV 2 using AXUTIL command.


  1. Export the .axmodel from Dev 1 USR layer

  2. Import it to DEV 2 VAR layer

  3. Has to be done AXUTIL

Don’t try to deal with two problems in the same time, because you can’t distinguish them. You should have tried to import the model to the same layer - if you got the same error, you would know that it wasn’t caused by layers.

Nevertheless you can’t import a model to a different layer. It’s clearly explained in How to: Export and Import a Model [AX 2012]: “A model is permanently associated with the layer that is created in. If you need to move one of your models from one layer to another, you must create a project from the model in the AOT, export the project as an xpo file, create a target model in the desired layer, delete the original model to avoid having to resolve layer conflicts, and import the xpo file to the target model.”

Consulting the documentation can save you a lot of time and effort.

You might also want to use my trick for moving in TFS.

Thanks Martin… I agreed and followed same as in MSDN. But I have another issue about the version. Saying

ERROR: The model file MyModel.axmodel is from a newer version of Microsoft Dynamics AX (version 6.0.1108.670) and cannot be installed."

I gone through the net and found some suggestion to check the version of the AXUtil and AXUtilLib in source and target environment. Both are same no conflict.

I checked the updates installed and found that the target system is missing the “Microsoft Dynamics AX 2012 Components” update in the control panel which is present in source system.

Kindly guide me on this.



Now you’re saying that the source environment is newer than the target environment, which is what the error says from the beginning. Upgrade the target environment to AX 2012 CU3, at least.