AOD Code upgrade from ax 2009 to ax 2012

hi all.

i am doing code upgrade process from ax 2009 to ax 2012.i have imported axvar.aod file from ax 2009 to ax 2012 through code upgrade checklist by using AOD code upgrade check list. intially it has shown the message"11823 objects are imported into var layer" and after that i have restarted the AOS and open the application in VAR layer mode. but here there is no objects are showing under the AOT. i tried again by deleting the VAR layer by using the command axutil delete /layer:var / db:MicrosoftDynamicsAXBaseline. i did the above process again but the issue remains same. imported objects are not showing under AOT.

is there any other steps to do?

can anyone help me please…?

You have to import the layer to both baseline and normal model store - did you perform both steps? If you import a layer only to baseline model store, you won’t see objects in AOT.

hi martin thank for your reply,

actually i did first step Import AOD file into the baseline model store that is importing into layer and it has shown a info message " imported xxxxx objects from var layer". after that i tried to perform the next step Import AOD into the new model store in the check list but it is showing the error " AOD file C:\Program Files\Microsoft Dynamics AX\60\Server\MicrosoftDynamicsAX2012\bin\Application\appl\Standard\axvar.aod for var layer not found."

can you please tell me what might be the reason? and how can i solve it?

You have to copy the AOD file to the expected location (see the exact path in the error message).

If you can, download training materials for Data Upgrade and Code Upgrade to Microsoft Dynamics AX 2012, you’ll find there answers to many questions.

hi martin,

Already i copied the ax 2009 axvar.aod into Old folder in Ax2012 application folder from there we imported the objects to VAR layer of 2012. and here i thought in the second step it will use VAR layer of 2012 to copy the objects into new model store. but it is not doing that and simply throwing error.

As you said i copied the same file agin from Old folder to standard folder and did the second step it works and now i am able to see the imported objects under AOT.

Thanks a lot martin…

Hi All,

I am doing Ax 2009 to Ax 2012 upgrade.

I am facing a problem during code upgrade. I was on 2nd step of Code Upgrade i.e. Import AOD File into New Model Store.

Initially i have copied AOD file into Old folder of application.

When i run step 2 : Import AOD File into New Model Store. It gave me error" File doe not exist at specified path.

After that i have copied usr.aod file into Application folder and run Step 2: It starts me giving error “Usr layer already exist”.

I am not able to understand what the problem is.

Can anyone help me how to resolve this.


Aman gupta


Hi Aman,

Along with above syntax you need to provide specified file path as well as server and database path.

if multiple aos in one environment

Import-AXmodelstore -File –Filename -servername -databasename–addparameterconflicts

if single aos

Hi Jagannath,

Thanks for the reply…

But i am unable to understand where i will provide parameters mentioned by you…


Aman Gupta

Hi Aman,

You need to write the code in microsoft dynamics ax2012 management shell.

However for parameter

Import-AXmodelstore -File –Filename -servername -database -databasename–addparameterconflicts

Filename would be " The total path".

server name would be “The AOS servername”

databasename name would be the database name which is pointing to the aos server.

While " addparameterconflicts" is not mandatory.

Best Regards,


@Aman Gupta: Delete all changes from USR layer and repeat the import.

(Please create a new thread next time, this one is already marked as answered.)

Thanks Martin,

But i am not able to see any USR layer changes in my AX 2012 environment.

How USR layer changes will reflect into my AX 2012 environment.


Aman Gupta

Create a new AOT project, open it and click Advanced Filter/Sort icon. In the Project Filter form, click Select, set usr as Criteria for Layer field and confirm.

Hi Martin,

I have already done that but i think there is a problem in application.

When i opening form to choose layer, system hangs down…


Aman gupta