Analysis Views not reconciling to GL

Hi, I journalled a GL entry with a Dimension Value. The GL Table is showing the entry correctly, but the Analysis View Table is showing the Dimension Value as blank. This seems to have only happened on 1 in every 1000 transactions. Does anyone know why, and if so how can we correct this please. Thanks a lot Vicky & Jonathan

This was a reported error in 3.60 but looking at the logs no-one could ever reproduce it for Microsoft so it was not resolved, that said this has not been “reported” to Microsoft after 3.60. Sorry no help here!

Change the control information in the Analysis View Card: this deletes all entries, then change the value back, then run Update Analysis View. Does this correc the fault?

Go to the the Analysis View card. Change any one of the parameters - this deletes the analysis view entries so could take some time. Chnage the parameter back to the original valeu and then run the Analysis View Update. I know this is a workaround but at leats you can reconcile the Analysis Views and the G/L!

Hi, Thanks for the replies. I have already tried emptying the analysis value entry table and re-creating it but it always fails to populate the dimension fields for these odd transactions. I’ve studied the affected transactions carefully but can’t see anything unusual about them - doesn’t appear to be a pattern. Thinking of running a quick update routine to fill in the missing dimension values from the GL entry table whenever the user requests an analysis report. Jonathan

Jonathan, Have you checked in the dimensions value is both in the G/L entry table and also the Ledger Entry Dimension table. I have in a few cases seen that the Ledger Entry Dimension Table was not correctly updated even though updated in the G/L entry table. Analysis view is created based on dimensions in Ledger Entry Dimension table. So insert them in the Ledger Entry Dimension table and then delete the analysis view and update again always solves my problem. KR Kim

Jonathan, I had the same problem and still do not know the real reason, but … it seemed that for these phantom entries dimensions were not correct in table 355 (Ledger Entry Dimension). So, if you renew this table, the analysis view entries will be generated correctly. Riina

Hi, Maybe all are right. … First create a report or codeunit to make sure the G/L Entry Dimension is consistant with Ledger Entry Dimension for Global Dimension 1 and 2. Second create another report to delete all analysis view entries for the analysis view card. Reset the Last Entry No. to Zero and then run the update. At last the bigger the G/L Entry grow…the bigger the headache we have… cheers, JHC

Hi! We have just experienced the same problem in 3.70 B, with all the hotfixes; analysis view doesn’t have all the dimensions as the Ledger Entry Dimension. And this have only happened a couple of times, and we can’t see any difference between the “good” ones and the “bad” ones. But what we know is that this have happened after the customer started to use “Dimension value combinations”. So I think maybe the problem has somehing to do with that?

Did anyone find a cause and solution to this problem…[8]


We have just encountered this issue, or a very similar one.

One of our 3.70A clients reported that an anticipated value was not appearing in the view for a certain account in the Analysis by Dimensions window for one of their analysis views. Strangely the other side of the transaction for the other account was showing up. They re-ran the update, but it made no difference (Auto update on posting was turned off).

Even more oddly they could see the relevant transaction in two other analysis views.

Looking at the Analysis View Entry table, filtering on the relevant G/L Entry number, I found three records. Two were correct, with the right G/L Account code, the right dimension, the right amount and posting date.

The third one is very, very wrong. It has the same G/L Entry no. but the G/L Account number is not one that refers to the relevant transaction. The Posting Date and Amounts are different and the dimension is blank. Indeed there is a record, but there are no dimensions at all on it.

How is it possible for an Analysis View Entry to be created for one G/L Entry with the details of another? I have tried to find the other entry that the details might refer to, but there are several transactions for the other posting date for that account and that value.

On a test copy of the database, I wiped out the entire Analysis View Entry history for that Analysis View and deleted the “Last Entry No.” field in the Analysis View and re-ran the update from the beginning. This fixed the data and it now shows the right entry details, but we would like to know why so we may fix this.

Many thanks in advance.


I have the same issue with NAV5.00. Some GL entries with dimensions are not in the Ledger Entry Dimension table (or with a wrong dimension).

Did you find a hotfix or something new ? Can you reproduce the issue ?

Many thanks,