AIF WebService Error

Hi All ,

Recently i have made a EmplTable Webservice and is running successfuly , but when I Insert new record into the EmplTable Form then it shows some error like :

AifRequestProcessor-processServiceRequest AifRequestProcessor-executeServiceOperation Error executing code: AxInternalBase object not initialized.


(S)\Classes\AxdBaseRead\serializeRecord - line 23

(S)\Classes\AxdBaseRead\serializeRecord - line 68

(S)\Classes\AxdBaseRead\serializeQuery - line 55

(S)\Classes\AxdBaseRead\serializeDocument - line 39

(S)\Classes\AxdBaseRead\findDocumentList - line 14

(S)\Classes\AxdBase\findList - line 65

(S)\Classes\AifDocumentService\findList - line 38

(S)\Classes\EmplEmplTableService\find - line 4


(S)\Classes\AifDispatcher\callServiceMethod - line 60

(S)\Classes\AifDispatcher\dispatchOperation - line 11

(S)\Classes\AifRequestProcessor\executeServiceOperation - line 20

(S)\Classes\AifRequestProcessor\processServiceRequest - line 101

(S)\Classes\AifRequestProcessor\processServiceMessage - line 36

Can any one help ,why I am getting this error and the solution for it. Please Reply ASAP.

Thanks & Regards



You said it was working before. So you need to check what has changed recently. Have you tried forward compiling AxInternalBase class? Also have you tried consuming the webservice from within AX? Does it work or do you get the same error there?