'Adjust Cost - Item Entries' never completes.

We are having a problem trying to run the ‘Adjust Cost - Item Entries’ Inventory periodic activity, in Attain 3.60 (native). The routine runs (‘Adjusting Value Entires…’), working through Items with entries, until it gets to the last item with any entries. It then says ‘Searching the Value Entry table, press Ctrl+Break to cancel…xxxx’ in the status bar, where xxxx is a number. This count goes round and round seemingly for ever (we’ve left it for 36+hours) without any other visible progress. This is being done on a test DB with hotfixes 1-16, 19, 22 & 27 applied. This routine hasn’t been run before, and there is a years worth of data in this DB. Is it possible it just needs to run for longer? Has anyone else seen this problem before? It doesn’t appear to be the same as the ‘endless loop’ problem detailed elsewhere on this forum. Any help would be greatly appreciated. Thanks, Duncan Lock.

Hello Duncan, Unless you have had some bespoke work done to your system, then I do not believe that Navision is looping. Given that you have had the system for a year, but have not run the routine before, does suggest that it does need to be left to run for longer. How large is your database? The message that Navision is searching the Value Entry Table indicates that Navision is trying to perform the routine but is struggling with the amount of data. Does the number in the message keep changing or is it frozen? If it is frozen then Navision may have “locked up” due to the amount of processing required, but if it keeps changing, then Navision is running, but struggling. Have you spoken to your NSC about the response/efficency?

Hi, Thanks for replying so quickly. The test DB is 8GB with 4.3Gb of data. The count in the status bar is changing but seems to be going round in circles, starting low, counting up in the same steps each time and then starting again. This is why I haven’t just left it running, as it appears to be looping. Tempted to it off now and leave it for as long as it takes, though. Dunc.

You may want to read the “Navision Costing Error Detection and Data Correction” White Paper released by Navision in November of 2003. There is a lot of discussion on how circular references can be created. In 3.60, there were conditions created that could lead to bad data. While the program was HotFixed to prevent this from occurring in the future, the data created prior to installing the HotFix may still be in error. - Dave Hutchinson

Try running it on a test system over a weekend. I have seen it do the searching value entries for at least 8 hours (with the current improvemnt). The good news is that it runs quicker the second time. [;)] I would also get familiar with the document in Dave’s post. There are more recent Hotfixes than 27 which are critical here.

Hi Duncan, Your situation is what i would say is much better than mine.We faced same problem for one of our client. Who has been using Navision since '99 and never ran this batch job.Now when we tried to run it used to take 5-6 days and breaks down after that.Database size is of tune of 45 GB.We tried it on Test system reducing entries which batch Job processes and it completed soon.One thing for sure once you run this batch completely , it wont take much time from next time.

Hi, Thanks for all the replies and suggestions, everyone. I’m getting hold of that whitepaper, sounds very useful, thanks David. Can anyone tell me (briefly) how you would go about cutting down the number of transactions that the routine looks at each time? Is there a way to run it in several passes, or filter it by date or something? Thanks, Duncan Lock

Hi, As I haven’t been able to talk to anyone at our NSC today and they’re about to pack up for the Easter Holiday weekend, could some kind soul post a link/ email me a copy of the Navision whitepaper “Navision Costing Error Detection and Data Correction” that David mentioned? Thanks very much, Dunc.

Hi, I have been experiencing the same problem. The batch job goes into an endless loop for an item. Can anybody please mail me the link or a copy of the whitepaper discussed above. Thanks Gaurav

We had a similar problem if I understand it correctly and we fixed it with in CU 5895 MakeMultiLevelAdjmt() //MaxLevels := 100; MaxLevels := 5000; and after that it worked. If anybody knows if there might be some bad results with this - please do tell.