Adding New Table in Product Entity ax 2012 r2 DMF/DIXF

Can some one please help me with Steps for Adding new table in Product Entity. I have a table “msftInventTable” where msftInventTable.InventTable == InventTable.REcid. Along with importing data into Product,InventTables I would like to import data into this table too using Product Entity. Can someone please help me with the steps to do ? I tried to add it in the query and tried with adding fields in Staging and all steps, but i dont understand what i am missing. I am unable to import data into this table. So Temporarily, i have used coding in insertUpdate method to import data. But this will impact performance , so I need some inputs. Please help. Thanks.

Hello raas,

are you getting some error ? can you specify exact behaviour of the system after steps you have followed

You can create a custom table in DIXF to import the data using create custom table

I am not getting any error. I don’t see the data is getting inserted into the table which i added to product entity.

I don’t want to create a seperate entity for the new table. I would like to add it to the Product entity so it will load the new table while loading the product, inventtables using Product entity.

is source to target mapping fine? means all your new fields are mapped correctly with target table fields?

Yes, Can you provide the steps to follow for adding table into existing product entity where custom table and invent table are related by using this relation “msftInventTable.InventTable == InventTable.REcid”. So I can verify.

here are the steps ,…/

for new table you can add the relation with inventtable which you have already done correct way as per your first post

One of the steps which i didnt do when I am adding table to entity from above link is that “I didnt create a new target entity after adding new table”. This is because I will loose all my mappings/messup my mappings if i do that. Because its very complex. I just did a refresh of the target entity but didnt recreate it. Does that matter? or its fine ?

Hello raas,
yes it is but first goto entity and click on modify target entity and check if your new fields are mapped coorectly or not, i have doubt that your missing this link only.

Hi Kunal,

Yes i have seen in Target entity mapping and all the fields are correctly mapped. But still i dont see data is getting inserted into new table.

Hello Raas,
then i will suggest to create new target entity to reflect the changes

I created a new target entity and it worked for first time and it inserted records in new child table. When i run the same for second time, its not updating. Instead its throwing an error "Results Record (‘xxxxx’) Cannot edit a record in “Custom table” .An update conflict occurred due to another user process deleting the record or changing one or more fields in the record.