Account Schedule report error

Hi all…

I’m having a problem with account schdule report.

After I run a account schdule report in one company, then go to a another company and

when I try to run a report in account schdules, it says that the previous report which I run from the previous company does not exsistes.

Can any one help me with this?


Microsoft Dynamics NAV


The Acc. Schedule Name does not exist. Identification fields and values: Name='CON-PL’




’CON-PL’ - This is the report that I run in previous company.

Hi, you have to create and configure acc. schedules names/lines for every company existing in your database: the data inserted for these entities are usable only in the company where creation was performed.

When you change company and try to open AccSchedules, NAV fetches from .zup file the saved settings for AccSched form parameters as they where when AccSched was opened previously, trying to reopen that schedule.

If current company does not have the same AccSched name defined, you get this error.

Hi Daniele…

That means if I have 6 companies and I have 5 Acc. schedule reports for each then I have to create 30 report names for each company?

Hi Modris…

Yes, but I delete the .zup file and run again. Still it asks for the previous report.

Even if it is the solution I cant tell the user to delete the .zup file after they run a report in account schedule.

Which version are you running? Classic or RTC?


Sorry for the late reply, I’m Using NAV 2013 R2 RTC

Does the problem still occour if you pass through Departments, opening “Account schedules” list and then choosing Overvierw → Print?


Yes, I tried it. But still the same issue. It asks for the previous schedule.

At this point I can only suggest to remove in “Acc. Schedule Overview” page the property SaveValues, restoring the value “No” and retry.

I don’t have any other clue…

Thanks for the effort Daniele.

I did as you said, but still the same issue.

Does anyone else having this problem?

Sorry, I even created an empty company in a Cronus 2013 R2 database but I wasn’t able to reproduce the error!