Account number for transaction type System rounding does not exist

Hi Everyone,

The Account in the System Rounding in General Ledger is already setup but we still encounter this error. Furthermore, we did a test in which we change the quantity of the same item from 0.10 to 0.90 and some of the Invoice did post and some doesn’t. I even tried to compute it manually and found no rounding issue. Currently our setup for penny difference is 0.00 & a rounding prices is 0.009, we also tried using 0.01 for both setup but we still encounter the same issue but not with all the Sales Order.

hope someone could help…




In system posting account, have you made setup for other accounts also like penny difference account and error account.



You would need to debug it and get a developer to tell you the logic on the call of the rounding. 0.00 would be an issue as this implies no rounding. 0.009 would also be an issue if your currency is to 2 dp, but I see this more on the penny rounding than the price difference because the price difference gets handled by the currency exchange.

When you say you have set the system rounding in the general ledger I presume you are talking about the system accounts, but there are a few here, you have penny difference in default currency, order invoice rounding and purchase invoice rounding off - are they all set?

Yes Adam, they are all set up.

Thanks for your quick reply.



Are you using foreign currency in transaction? Also increase the penny difference in parameter to 2 and try to post the transaction.


If “everything” is setup and there is nothing unusual about the transaction (imported etc) and there are no modifications impacting on any of the sales order processing then I would get teh edveloper to debug it and tell you exactly the data point/code causing the issue.

Hi Pranav,

There are no foreign currency transaction for this…

Hi Adam,

Yes. I’ll ask our developers to debug it.

thank you very much.


Hi Heylin,

Make sure that the ledger account associated with rounding account has been included in COA configurational also… if you are working on AX 2012.


Hi there dou you have a solution for this? I face the same problem when I try to import import at our datamigration.

As I heared from a colleague the problem is that method “serviceCreateLedgerDimension” in class DimensionDefaultingService returns something weird.