'A call to the Microsoft Dynamics AX SRSFrameworkService service failed. The target principal name is incorrect.' when print SSRS Report AX 2012

Hi All,

It’s my first time using AX 2012.

I have installed Microsoft Dynamics AX 2012 R2, using database Microsoft SQL Server 2008 R2.

Everything looks fine. until I try to print report in client AX. it shows error ‘The target principal name is incorrect’.

To solve this issue I try several action :

  1. Define Bussiness Connector Proxy account

  2. Compile full CIL and register BIServices.

  3. Create new Report Server

  4. Define Service Account and Execution Account in Reporting Service to be the same as BC Proxy Account.

  5. Create new SSRS Report in Visual Studio. When I try to ‘deploy element’ my new SSRS Report in AOT. It shows ‘A call to the Microsoft Dynamics AX SRSFrameworkService service failed. The target principal name is incorrect’

Can anyone suggest what’s wrong and any idea to solve my problem ?

Regards,

Alwin

Hi Alwin,

Just make sure that Microsoft Dynamics service is started & try to open the report server and ensure its opening without any errors.

Hi Vishal,

just like I said everything looks ‘normal’ :slight_smile: . I can access all module and create transaction, and it just work fine.

AOS and SQLReportingServices started.

Oh ya one more point when I try to view report in directories ‘DynamicsAX’ at report server through address : http://serverax/Reports.

it shows error ’ The ‘AX_CompanyName’ parameter is missing value’

Try this

Goto System administration > Setup > Services & Application Integration Framework > Inbound ports.

Select BIServices port, Activate it.

I want to share a post from my blog that fix it

http://www.dynamicsaxlatino.com/error-al-implementar-o-realizar-deploy-de-un-reporte-desde-visual-studio-o-dynamics-ax/

Hello Carlos, when I click in the button ‘Register Service’ a frame is opened like this
What can I do?

Regards,

Well, using an admin account on the server, I just deployed and no errors appeared…This could be a solution. :slight_smile:

I am getting the same error… BI services is working fine
I deployed the service group: BIServices and UserSessionService, also refreshed SRSFrameworkService and SSASFrameworkService
restarted the AOS, restarted the SQL server reporting services and re-booted the VM too but no luck still
Getting the same error
What shall I do? Please advice
FYI I am working Dynamics AX 2012 R2
Thanks,
Shankar Iyer :slight_smile: