Wrong characters in records imported by DataPort object

I created a Dataport to import customer data.

Created a csv format file and every thing until know was ok. But after import to Navision, some text fields became with bad characters, like ascii ones.

How can I avoid that?


Don’t use UNICODE in your .csv files. Everybody knows Navision does NOT suport UNICODE [:’(]

If you “save as CSV”, for example, in Excel, there are two formats - CSV and CSV(MS-DOS). The second is the right one.

That is my option CSV(MS-DOS), but here in Portugal we have use some characters, like Ç,á, é,ão…and this one in navision becames bad characters.

My native Latvian also contains accented characters (actually my surname is Īvāns, not Ivans), so I have fighted with this same problem extensively…

These characters exist in non-Unicode encodings, too. In Win Regional settings there is Advanced tab - select Language to match language version of non_unicode bla bla bla. Check what you have there, should be Portugal in your case. The long list of Codepage conversion tables must be adequately set up, too.

Besides, you must create the datafiles in an editor, where you can select encoding, Excel by default uses UNICODE, and does not always convert the encoding when Save As CSV(MS-DOS) is performed. Accented chars in texts written in ANSI / ISO / OEM encodings appear as garbage in Excel, but OK in Navision.

Best way is to prepare the data and do import on the SAME computer, because if there were different conversion settings, results can be unpredictable. Check from the contrary - copy/paste text from Navision to Excel and look if you get garbage or normal result.

We solved the “Strange” charaters by doing this…
Go to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
And change the “OEMCP” value to “1252” (or the same as ACP)

My OEMCP was 437. Have to do it on all machines though.

I’m sure there is a converter also that you can use in the download section. If not It can also be found here:
plus some related downloads at the bottom you can try too.