Windows Authentication with SQL 2005

Hi, I have installed SQL server 2005 (64 bit). I have created the extended stored procedure for 64 bit version, but I am still not able to create the new database for Navision using widows authentication. I am using W1 SP1 version. Please Suggest. Thanks

What is the error message? Does your user account have enough rights to create a database in SQL Server?

HI, The error message is: --------------------------- Microsoft Business Solutions-Navision --------------------------- The following SQL Server error(s) occurred: 17750,“42000”,[Microsoft][ODBC SQL Server Driver][SQL Server]Could not load the DLL C:\Program Files (x86)\Microsoft SQL Server\80\Tools\Binn\xp_ndo64.dll, or one of the DLLs it references. Reason: 193(%1 is not a valid Win32 application.). SQL: INSERT INTO [#$ndo$groups] {CALL [master]…xp_ndo_enumusergroups} --------------------------- OK --------------------------- I am using administrator rights on systsm as well as on SQL server (Logged in as SA). Thanks, Girish

Have you setup the SQL server for SQL Server and WIndows Authentication Mode. Cheers, Prashant

It looks like you haven’t registered xp_ndo64.dll file. Please register it on SQL. The installation manual explains on how to do it.

Hi, I have installed SQL server in Mixed Mode and also created the extended stored procedures using xp_ndo64.dll file.

Did this get solved? I am having the same problem and I am not able to get it to work. I added both extended procedures, restarted the system, removed the procedures, readded the procedures, loaded the 64 bit procedures (on a 64 bit processor), made sure public had permission to execute.

I am still getting the error exactly as above (not a valid Win32). I appreciate any additional assistance.

This might do it…

You get an error when starting a Windows Service:

Error 193: %1 is not a valid Win32 application

This could be caused by a folder on your hard drive that has a similar name to the folder that contains the path to the service. For example, if the path of the executable file for a service is C:\Program Files\ProgramName\ServiceName.exe, and if a folder that is named C:\Program also exists on your hard disk, Windows locates the C:\Program folder on your hard disk before the C:\Program Files\ProgramName\ServiceName.exe file, and then tries to run it.

You can get rid of the Program folder, or perform the following steps:

1. Click Start > Run and type REGEDIT and click OK.

  1. Click the plus sign next to HKEY_LOCAL_MACHINE
    then SYSTEM
    then CurrentControlSet
    then Services
    then ServiceName

  2. Right-click ImagePath on the right side. In the Value data box, place quotes in the path.


Change: C:\Program Files\ProgramName\ServiceName.exe

To: “C:\Program Files\ProgramName\ServiceName.exe”

  1. Click OK and close REGEDIT. Restart the computer.

Hope it helps


Sorry, just read that again and maybe rather than being a problem with the service, you might have a similarly named folder to the one where you have installed your extended procedures, so perhaps investigate that first.

Hope it is of some help.


P.S. I tried to amend my original post, but it keeps coming back with the old one, anybody have any ideas why?

Thanks for the help.

Microsoft released a new DLL for 64 bit machines, xp_ndo_x64.dll.

Hi Girish, did you ever get to the bottom of this problem?? I’m having the same issue.