when use the webservice, the iexplore need i type the userid and password.

hello, everybody!

i have published a webservice in object designer,

but when i use the url(http://machinename:7047/DynamicsNAV/WS/Services) to work, the iexpore let me to input the useid and password.

can the webservice work in a anonymous way?


Shot in the dark here, as it is not my thing, but it might be a problem with the trusted sites. I think it is under Tools → Internet Options → Security Tab → Sites button.

Again, just a guess. We have had issues before where internal sites could not be accessed and prompted for a user name and password. Adding them as trusted sites prevented it.

As per my exp,

if we give machinename, it wont ask userid and password

if we give, machinename@domain, it will ask for userid and password…