What MADMAN wrote the installation guide :)

You know as a noob here, it took me 15 minuts to download VtigerCRM, and 10 more to run and install. Now no way is it the same I admit, but I am trying to do some customisation on a demo and show to people, and its really painful.

Why I cannot find a VHD file on Microsoft’s website or access from them a VM that is not timed to expire in 2hours I do not know. I tried to change their preferred hosters VM to GB settings and it crashed… oops.

Meanwhile I was parallel running a SAP Business One on another VM install and, its more or less a one trick pony aka run it and watch. Not saying the final product is but who WROTE the INSTALL , would the maniac please stand up. :frowning:

So to the story…

1 VM(1) Installed on Server 2012 - FAILED as OS binaries effectively more recent than installation routine could cope with, and various attempts to find install switches or fake the OS failed.

2 (VM(2) New Hyper-V VM - Installed on :

  • Server 2008 RC2

  • domain joined

  • New AD OU with accounts added that are allowed to run as batch/service, with group policy excluded from overwriting

  • 2008 SQL Enterprise and reporting running and tested good to go

-SharePoint 2010 Essentials test and running good to go

-Search Express 2010 with all SP’s and updates from everything above, tested and good to go

  • Dynamics AX 2012 prerequisites - all 53 I think from memory - good to go

NOW AT this point I am pretty much FED UP - I APPRECIATE Microsoft paid a team of guys to beef up the command prompt and we now have powershell (and dynamics cmdlets), so why the F’in hell do we not have a SINGLE DVD ISO that contains ALL OF ABOVE, asks for options, installs all the users if given the right logon, and does below by such, oh and WORKS!

I am tempted after now on my fifth day of this, to do it. Anyway back to the story…

Failed as silly me the official install guide at various pages across the 187 page guide asks for credentials to be created. Hmmm… perhaps just listing on one single page the SQL/MOSS/Dynamics/Search/AOS/ServiceAccounts and roles would be nice!!!

3-8 VM(3-4-5-6-7-8) honestly not exaggerating - I was tying standalone, how nieve) and as I do not have SSD drives its a painful wait each time to restart from a backup VM as its now nudging 50gb on disk.

9 VM OK so now we are cooking…

Dynamics - databases installed

  • AOS and .Net connector installed

  • Client utils installed

FAILED - tried to then install EP/HELP at same time

10/11 VM FAILED - tried to install EP by itself; 11 VM (was getting bored) tried the Give Every Account GOD/sa/domainadmin rights to the local VM/domain/SQL for a laugh - no joy

11 VM Failed - noticed in IIS that new App Pools for Dynamics AX there/2 new templates in MOSS, but separate install from SharePoint admin failed

12 Rolled Back to no.9 snapshot, decided as have databases, AOS, .Net, Client let’s compile. Added license key, no issues, configured app functionality no errors, went to compile application - 153 Errors and counting so killed the VM, back to no.9 again. FAILED

13 Recompiled - STOP errors after 4.5 hours processing, relating to one AIK table reference item not existing. FAILED but no other Errors. Being a bloody optimist, I am currently continuing right now, and Compiling into .NET Framework. It is the randomness of above that is annoying me and the install guide sucks as does not help. Luckily some folks online here, and elsewhere have some install guides, that have no bearing to the Microsoft one, so are worth reading.

14 Who Knows - will hope above works!!! this post to be CONTINUED [:P]

Update #002

To continue the story…

13 FAILED - after leaving running literally all night, compile had not completed, perhaps low memory assigned - process killed.

14 VM New instance from no.9 - Installed Analysis services fine, but failed to install report services. I checked the SQL report config and its fine, and the URL’s are working - presumably you need to install EP and a site collector first as a guess (shame that was not in the install routine :frowning: ) FAILED

15 VM New instance from no.9 with catchup on items that did work (analysis services) - Install EP attempted again - Took the path of negativity, and chose NOT to instal sharepoint or restart IIS, and EP installed, woo hoo!!! Waiting now while another batch of new windows updates (14) are being deployed, must be related to the Analysis Services somehow as there was nothing yesterday evening on windows update.

To be continued…

As an aside: I have separately tested in MOSS creation of New Sites/SiteCollectors/Farm Admin user list and all good. Also adding Search across all sites works as well. So before anyone shouts out its my ACL rights in MOSS I will say no its not from what I can see.

…yes I am waiting for server to reboot hence free time…

Now one could argue that I could have created ONE user called DYNAMICADMIN on the domain, given him local admin rights to the server, domain admin rights on the domain, ability to logon as batch/service, and made him sa/root/god equivalent on SQL server and all databases (dbo), logged on to the VM as that user. But a demo for me at least means people will ask about segregation of duties so I have to clearly break out every unique service/role and take the path of least rights.