Warning message while starting NAS

The following warning message appear in Event Viewer when i run NAS

The description for Event ID ( 109 ) in Source ( Imran ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer.

Imran is my computer name. I have given the same name Imran for Nav database server and sql server.

any ideas?

Any way , i am trying on NAS for almost the first time , i have dont everything mentioned in the manual but i dont able to see any result. ?!?

Hi Imran,

Is that the full message?

Kine has a description in his blog, as how to correct the entries in the registration database, so that the error-message can be “translated”.
http://dynamicsuser.net/blogs/kine/archive/2006/12/18/6415.aspx

If the message appears just as son as You try to start the NAS, then You can also look into whether or not You have the correct startup-parameters.
Have You pointed to an existing company, in an existing database, on an existing server?
Have the account that runs the NAS-service, the nessecary rights to log into NAV?
Do You start it with a parameter, that actually can be used in CU1?

Below is the full message:

The description for Event ID ( 109 ) in Source ( ALFNAR-5BEC4C44 ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: The combination of user ID and password entered is invalid. Try again.

Everything seems to be alright. i have correct parameter. I am using the same parameter in CU1. The server is existing, database is existing and the company is existing. I have the account, the username and the password, but there isnt any place to put username and passort in order to start the service. Isnt it??

NAS uses Windows authentication

As Nuno says the NAS can only use windows-authentication.

In the Property-sheet of the service itself, You find a pane called “Logon”.
In this You define wich domain-account that starts the service. This account must also be given access to Navision, as it is this the NAS uses to log into Navision.

Yeah this is the problem, i have to setup the database using windows authentication. Thanks all.


Microsoft Business Solutions-Navision

The extended stored procedure xp_ndo_enumusergroups in the library file xp_ndo.dll, is not available on the Imran server.

Until this procedure and library have been added, it will not be possible to connect to this server from Microsoft Business Solutions-Navision with Windows Authentication, but you will still be able to connect with Database Server Authentication.

You can read more about adding this extended stored procedure in the help pages on the product CD. Follow the hyperlink to the readme.txt file on the Servers page under the Documentation section of SQL Server.


OK

I get this error, i have xp_ndo.dll in the navision cd but where to place it. Please guide me.

In installation cd you have a folder called Sql_esp. File readme.txt explain all the steps you have to make.

ok all done. Now everything seems to be ok. i have put the user and password too. but when i run the service, nothing seems to be happening in the database. I have created a parameter in CU1, which suppose to run a message…but i dont see any.

any ideas?

Messages are displayed in event viewer