Upgrade from 3.01b to 3.60

Hi! I’ve just upgraded our database from 3.01B to 3.60 (not the database objects) - and we’ve got two problems I don’t find a solution to: 1. The Navigate function in the Customer Ledger Entries doesn’t work proberly when we have an Document No. with an letter as prefix (ex. P10000) - we get an error message that sais : “You can not enter P10000 in Code. The cursor is in front of the invalid character.” 2. In 3.01B we used the SHELL function to open word documents. When we use the same function after the upgrade, we only get to open word, but not the doucmemt. No error messages appears. I would appresiate if someone could help me with these problems.

Raa, I’m not too sure about your first problem but you can get around the second one by using the C/AL function HYPERLINK. Just pass the path and file name as a parameter to this function and it will open it with the appropriate application. It is much more flexible than the SHELL command as it uses the OS to match registered applications with file suffixes. This means that it will open *.xls files with Excel, *.doc files with word and so on. Regards, Chris.

Hi CMGW! I’ve found some topics about the HYPERLINK function, but I cant get it to work properly. I tried with: HYPERLINK (‘path to the file including file name and extension’) on files with the extension .doc, but the Internet Explorer opens (not Word). But I’ve found another solution to the SHELL problem. It is that the arg1 and arg2 in the SHELL function in 3.60 doesn’t work properly. If one put the arguments togehter in a vaiable then it works. Before: SHELL(‘c:\joe\myprog.exe’, ‘arg1’, ‘arg2’); In 3.60: var - File Text 250 File := ‘c:\joe\myprog.exe’ + ’ ’ + ‘arg1’ + ’ ’ + ‘arg2’; SHELL(File); That is the same as Chris suggest, but still using SHELL. regads Raa

Raa, I’m glad to see you have solved your problem but your reply to my posting made me check my use of the HYPERLINK function. In my system it does work as I first described so there may be a difference in the default application that is linked with *.doc files… In “Folder Options” under the “Tools” menu in Windows Explorer there is a “File Types” tab in which you can specify the application to use for each file suffix. To test this on my system (Win 2000 server) I changed it so *.docs file shold open in Notepad and this did take effect when I tried the HYPERLINK function in Navision. I would be interested to know if this works on your system as I had planned to deploy some functionality at a customer site using this function and would rather find problems now. Thanks, Chris.

Chris! I’ve tried a few times and came to an conclusion. The HYPERLINK function works when the documents are stored locally on my computer or at a mapped up network drive. The functions that i’m running shall open documents from a data storage server that may not be mapped up on every klients. Then the HYPERLINK use Internet Explorer as default program. My results are: HYPERLINK(’\Servername\DocumentCataloge\DocumentName.doc’) does not work. HYPERLINK(‘c:\DocumentCataloge\DocumentName.doc’) and HYPERLINK(‘o:\DocumentCataloge\DocumentName.doc’) does work. Vidar!