Updating Analysis Views in Nav 4 SP2

Hi Forum, for some strange reason the Analysis Views are not reflecting the Opening Balances that were entered via a General Journal. I can see activity by Dimension that has been done since the Analysis By Dimension was written but not activity before it was written. The General Journal that was used to post the opening balances did has the Global Dimensions filled in. Can anyone shed any light please…Paul

Before you run the view, update it. Someone may have turned off automatic updates (which is a good thing, as long as you know that it is turned off)

What you need to do to reset the analysis view is change a property, date compression to a value, Navision will ask that it will reset the data. Click yes, then run update afterwards, which will rebuild the analysis view. Also make sure you run optemize on it.

Hi ara3n, I changed the Date Compression and then updated but it made no difference. However I have noticed something strange in as much as when I run the Analysis view with a date filter of 01/01/06…C31/01/06 it shows the Total Amount but IF I drill down on this Total Amount, the Global Dimension 1 Code (showroom) does NOT show any dimemnsion values for any of the Opening Balances that were posted with a Posting Date of 27/01/06 via the General Journal even though Global Diemnsion 1 Code values were present on the Journal. The only transactions that show the dimension code is the transaction that was done yesterday.

Should the Accounts that the Opening Balances were posted to have had the Global Dimension 1 Code defined beforehand because I assumed rightly or wrongly that the Analysis View would work off the GL Entries and the value of the dim codes posted. I hope all the above makes sense… Paul

Hi, I have noticed something else that seems strange. When I run the Analysis View with a filter of 01/01/06…C31/01/06 I see the Total Amount for the Opening Balances entries that were posted wih a date of 27/01/06 BUT when I drill down on the Total Amount for one of the account codes I see 1 Analysis View Entry without a Dim value as mentioned previously but then IF I drilldown of the Amount fields I see no General Ledger Enties. If I do the same for the transaction that was posted yesterday I see 1 Analysis View Entry and 1 General Ledger Entry both with Dim Values. Now I’m confused…Paul

One other thing I should point out, a DataPort was used to load the Opening Balances onto the General Journal. No validation was performed on any of the DataPort fields.

Hi Paul

You might have posted a Journal with inconsistent dimensions. You say you loaded the journal with a dataport but didn’t do any validation. Could you try to look at the created G/L Entries and confirm that Global Dimension 1 is present on the G/L Entry as well as in the Ledger Entry Dimension Table? I suspect the dimension only is in one of the two places and this could cause you the issue you are seeing.



Yep that would do it for sure. At a quick guess, is it Global dimensions causing the problem? If so then a possible solution, is to go to Setup, and change the global dimensions to something else, and then change them back. This MAY revalidate creating the necessary dimension tables, depending on exactly what was done wrong during the dataport, but it also might just erase what you have now, so do it ina test DB first of course.

If the dimensions are lost from the dimension tables, then you are going to have to get the screw drivers out to fix the data.

Hi Claus and David, you guys were right. The entries are NOT on the Ledger Entry Dimension table and I think its gunna talk more than a screwdriver to fix this. The only entries that are, are the two that were entered by hand via the General Journal after the 3,800 lines uploaded via a Dataport were posted. I also noticed that a number of other fields werent populated via the dataport so I changed the spreadsheet and Dataport and added them BUT this made no flaming difference.

I tried uploading just two lines to investigate all this and noticed that if I validated the account code after the dataport had uploaded them by pressing the up arrow and pressing OK on the COA list, this populated all the missing fields BUT I wouldnt want to do that to 3,800 lines (and that was just period 1). I know you can write a routine to do the validate for you but dont know how and anyway that would overwrite my descriptions with the account code description.

Is there anything else I can do resolve this without changing the Gobal Dims? as Im really at a loss on this one.

Last resort would be to create the routine to revalidate the account codes if someone could send me the coding in a PM but then I would have to re construct the description via a nother Dataport perhaps. Paul [:’(]…

I wish I was back in The Land of The Long White Cloud right now

Hi Guys, I got to the bottom of why this is happening but dont know how I can automate the process to save me hours.

Basically, when I dataported up the journals complete with Global Dimension 1 Code for the various showrooms, as previously said by yourselves the Dim value was not being handled correctly. So what I did was revalidate each dim value by pressing the uparrow in the Gobal Dim 1 Code field and then pressing OK at the Dimension Value List but this took an age with 4,464 lines. If was worth it because the Analysis by Dim now works, so is it possible that routine be written that is run against the Gen. Journal Line table to do this process for me to save me pressing the uparrow and then pressing OK(many years back I was given a routine which revalidated GL Accounts because Posting Groups werent being brought thru). If need be, this thread can be moved to the Dev Forum so that I could be supplied with the code to do this IF it is possible.

I think there is finally light at the end of the tunnel

Problem solved, I put a Validate on the Shortcut Dimension 1 Code in the OnAfterImportRecord trigger and that solves the problem completely…[:D]