Unable to start Navision service on Navision 2009 R2?

Hi everyone i have installed navision 2009 R2.

Classic is working fine but for RTC as i try to start my service it gives an error

"The Microsoft Dynamics NAV Business Web Services service on Local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service."

I tried using adminstrator user account, local system account and as network service but its not getting started.

Can anybody have idea how to do it.

Please reply

Thanks in advance.:slight_smile:

please mail me your error Screen Shot in my id arun.shaw@bishalgroup.com.

Try to check the Windows application log for more details on why the service failed to start. By looking at the error you got during the install, it sounds as though your user account does not have permission to start services on the server regardless of which credentials your service is running under.

Thanks Gaspode,

I tried to work around the solution as you suggested, and then a new error which i received.

I am attaching the error with the reply please check and revert back if possible.

5516.new error.JPG

Now when i try to start RTC, the exact error is this…

6320.newerror1.JPG

Hi Saurav,

How did you solve this fatal error?

Hi Mohan,

Yes the issue have been resolved.

The issue is resolved by Changing The Default time zone in the custom setting file.

For Details Please check

http://saurav-nav.blogspot.com/2011/05/error-after-installation-of-microsoft.html

Regards,

Saurav Dhyani

NAV- Developer

BLOG- http://saurav-nav.blogspot.com/

Hi Saurav,

but in my case nav service is not installed at all [:(]

…may be it installed in your case.

Hi mohan,

It is not possible if you have installed the Demo option from the setup.

The service tier and the database tier only get installed on your machine if u install demo.

Regards

Saurav dhyani

then how do i install?

Hi mohan,

what i want to say is -

If you have installed navision using INSTALL DEMO option, then the service and database tier get installed in your local machine.

Let me know which option you have choosen during installation.

Regards,

Saurav Dhyani

http://saurav-nav.blogspot.com/

Demo only, i too got the same error which you shared above but service is not installed (not client-server enviroment)

Hi mohan,

when we choose install demo option three things get installed in local machine -

  1. NAVISION Classic and RTC Clients.

  2. Navision server.

  3. Database Server.

Check out for same in c:\Program Files\Microsoft Dynamics NAV\60\ (default location of navision).

There should be folders Classic,RoleTailored Client,Service and others.

So service folder have a customsetting.config file where we tell RTC Client the database server name, database name, port number and other thing.

IF after installation there is no service tier, you need to install it again or you need to create the service manually.

Regards,

Saurav dhyani

Thanks for your valuable information…

In C drive Service folder is not installed and If I try to install Service manually it is displaying

[Window Title]

Windows Installer

[Main Instruction]

Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel.

[OK]

You can find my full post here

http://dynamicsuser.net/forums/t/42607.aspx