unable to open a report?????????

hi friends....
when i am trying to open a report in any module....error coming like this
anyone know the solution let me know.....
thanks in advance......

Error executing code: SysReportRun (object) has no valid runable code in method 'reportFindMethodsMap'.

(S)\Classes\SysReportRun\reportFindMethodsMap
(S)\Classes\SysReportRun\reportHasMethod - line 6
(S)\Classes\SysReportRun\_allowSaveLast - line 8
(S)\Classes\RunbaseReportStd\allowSaveLast - line 5
(S)\Classes\RunBaseBatch\getLast - line 10
(S)\Classes\RunbaseReportStd\getLast - line 6
(S)\Classes\RunBase\promptPrim - line 9
(S)\Classes\RunBase\prompt - line 12
(S)\Classes\RunBaseBatch\prompt - line 32
(S)\Classes\RunBaseReport\prompt - line 13
(S)\Classes\SysReportRun\run - line 13
(S)\Classes\MenuFunction\runServer

Hi Nagendra,

I think you need to check your code in reportFindMethodsmap().

thanks for your response…

but

i did not modified the code… it is system level class…

Hi Nagendra,

Then may be due to synchronise issue, you try compling the whole AOT.

First go to Administration → Periodic → SQL Administration → All Tables / All Indexes ->synchronize. then compile the AOT

hi lilly. thanks for your reply

i have done what your said…but i am getting same issue…

is there any other chance…

Hi Nagendra,

use compile forward option and run again it may be work .

hi Raj…

thanks for your reply

i Tried compile Forward to SysReportRun Class…still i am getting the same error when open the reports in Gen ledger…ie

Error executing code: SysReportRun (object) has no valid runable code in method ‘reportFindMethodsMap’.

hi…

just go to that class->method() and compile it , and run again it may work.