Timer event doesn't fire when running NAS

I have a single instance codeunit with a loop polling a table and it’s working just fine if I start it manually from Object Designer. But when i run it with NAS it just runs once. The timer doesn’t seem to work. I have confirmed that my single instance codeunit is started from codeunit 1, but it’s just run once… When running it manually I use the same user, so the only difference is NAS or a real client. Any ideas?


No. That’s not my problem. My code runs perfect when i start my codeunit from Object Designer, but with NAS the timer event only happens once. No messages in the event log.


My code runs perfect when i start my codeunit from Object Designer

Does it normal end ? Or is there perhaps the possibilty of endless looping while running in NAS ? I had a similar problem in NAS while the NAS-Job was locked through users. A LOCKTABE in the beginning was the solution

I’ve had problems with Windows 2003 and virtual machine programs. Is this your setup? Also, is it single instance?

No. I run on my XP Notebook for testing. I think it has something to do with the environment I’m running it in. This isn’t the first time i do this kind of “table polling” with NAS, but I’ve never had this problem. It all works perfect when running the singel instance codeunit directly from object designer. The timer event fires perfectly for hours if i want to an scannes my table for something to do, but with NAS… I’ll give it a try in another environment to see if it has something to do with that.