The Value of Round Parameter

Hi Folks…

We recently upgrade Nav 5 (exe) to Nav 2009 R2 (exe)

since then every day users get a message when try to post a Jnl.

The value of ROUND parameter 2 is outside of the permitted range

The Current Value is: 0.
The Permitted Range is: 1 to 2147483647.

I’ve input 0.00001 into G/L Setup Unit-amount rounding precision ALSO I input the same into the currencies table

This allows the user to post their Jnls.

Does anyone know why my input into the 2 tables are reverting back to ‘0’ and not being saved?

Nav 2009 Classic

3.6 Database

Regards

Paddy

Activate debugger and check where you are getting error…

IS there any customizations done ??

Thanks for the reply fellas…

I’ll dug it tonight as I don’t want to stop users posting.

We have a lot of customizations as we been using NAV since 2004…

I’ll keep you both posted

Cheers

Paddy

Make sure that all fields in General Ledger Setup with name **Rounding Precision are not 0.

Hi Mohana…

last night I ensured the G/L Setup all had values within them other than ‘0’. However this morning the G/L setup table have all reverted back to ‘0’???

Debugged the jnl posting and it was falling over on the Table 83 RetrieveCost() .

IF Item.“Costing Method” <> Item.“Costing Method”::Standard THEN
UnitCost := ROUND(
UnitCost * (1 + “Indirect Cost %” / 100) + “Overhead Rate”,GLSetup.“Unit-Amount Rounding Precision”);

I know I can hard code this by removing the GLSetup.“Unit-Amount Rounding Precision” to 0.01… BUT really the question is WHY doesn’t my G/L Setup table keep the values?

Regards

Paddy

Check whether you have any code in OnOpen form or someother trigger?

I am sure it is a customization at your end.

There is only this code within form 118

OnOpen form
RESET;
IF NOT GET THEN
INSERT;

CurrForm.UPDATECONTROLS;

Compare the table and form with Cronus objects…

Unit-Amount Round was set to 2 on our Live DB. Cronus had 2:5 but both had 0.00001 as the Unit-Amount Rounding Precision.

I live in hope [O]

I didnt mean the values…

I mean the coding…

no difference within the coding

Then your values should stay as you entered…

or is there any job scheduled to update them?

or someone manually changing?

Found a sched job BUT it set to NORMAL not ACTION… I’ve disabled it now!!

see what tomorrow brings…

(Thanks for your time on this Mohana)…

Make sure that it is related to the present issue…not something like Adjust Cost - Item Entries batch job…