The user session does not exist

Hi !

We are getting an error " The User Session does not exist".

Connection ID = '53"

Can anyone please guide me what could be the possible error and suggest any solution if you have!

Thanks in advance!

Best Regards,


Hi Nat,

Could you tell us when and where this error happens? And what version are you running?

Sorry I forget to mention the version . Infact it is 4.0, SP 1.

It is for a particular user , The colums are the Global dimension 1 and Global Dimension 2 . The module is Human Resourse, Employee Card.

While updating the employee card by that particular user. The user picks a value from the list i.e Global Dimension 1 an Global Dimension 2… It shows the below mentioned error

The User Session does not exist.

User ID = ‘ERP’, Connection ID =53’

User ID = ‘ERP’, Connection ID =53’

We are using Microsft Navision 4.0 SP1. with SQL database. One of user while updating a Emplyee card , particulary the Global Dimension1 and Global Dimension 2. It prompts the below mentioned erroa dn doesnt allow to update the columns whereas it works fine with other users id’s.

The users Session does not exist

Identification feilds and values:

User ID = ERP; Connection ID =53

User ID - ERP, Connection ID = 53

Can anyone ever faced such error either aware of this solution please help us out to resolve this problem.

Thanks in advance!


On how many clients do you have NAV installed?
Would it be worth to consider a “technical upgrade” meaning just to exchange the clients to a newer version (suggesting at least 4.03 clients and 5.02 if you are under maintenance).

We have installed Nav on around 15 clients. Thanks We are not considering now for any upgrade as of now.

Plese suggest if you have any solution to fix this problem.




I think Thomas actually gave you a suggestion to what might solve it.

What version of SQL-server are you on?
If you use SQL2005, then you should at least move to 4.03.

Note that what Thomas talks about is a TECHNICAL upgrade, wich means changing the clients.
Not upgrading fully with objects and all.
A technical upgrade is not that costly.

Have you tried to catch the error with the debugger?

Just out of curiosity…
Why start a new thread with exactly the same question?
You already have started another… (

Thnks Thoms /Alexander

We are using SQL Server 2000!

This problem occurs with particular user only irrespective of any desktop he /she works.

I cannot answer you why, but just say that maybe NAT could not find his original post as I moved it from the forum where he originally posted it (the NAV Supply Chain / Manufacturing Forum to the SQL forum), so he posted a new post to the Supply Chain / Manufactoring Forum.

But now I have merged the two posts into one. So NAT please don’t post this topic again. [:)]


Could you please check if the user in question has different permissions on the SQL-server than the others.
(In Enterprise Manager)

You never told me if you can catch this error with the debugger?

This user had all those permissions on SQL Server as other users.

Unfournatly, I tried with the debugger but I could not catch this error .



“User ID = ERP; Connection ID =53”
Is this the session of the current user in question, or is it some other user-session?

Have you made any modifications to table 5200 outside Navision?
Some SQL-trigger replicating data to another DB.

Did you try to synchronize the security for all logins?

Are you using SQL or Windows authentication? If using SQL authentication, did you try to delete the user in NAV and on SQL and try to recreate it?

No, ‘ERP’ is was just an example, otherwise you are right this is the problem with the particular user id.

Yes the table 5200 is modified .

Can you please expalin ‘Some SQL-trigger replicating data to another DB’ about this and how to trace it about this event ?

Please also have a look at what Thomas asked…
These things must also be tried.
(Actually it’s some of the obvious things to try, i just didn’t think of it [:D])

What i mean by the SQL-trigger thing is whether or not triggers have been created in the SQL-level.
Go to the Enterprise Manger, and look at the table definition.

Hi !

Yes I tried using syncronize for all logins but unfournatley no sucess.

We are using SQL authentication.

However, I had created a new user id and allowed all those permissions given to the other user for which it is working but still the same problem arised.

Can you please advice any alternate solution.

Thanks in advance!

Could you please help me out if you have any resolution to this problem!

Thanks in advance!


Could you please try if the user can change the dimensions for an employee by using the “Employee” button and select “Dimensions” from there instead of assigning the dimensions in the card directly?

The Dimension fields are not included to the employee card by default. This must be a customization.