The entries must be seperated by document number or an empty line Error

Hello to everybody

I use NAV 5.0 ,SQL DB

I want to post in Payment Journal the following transactions

Bank Account, Document No. A1, Credit 5 500 LCY

Vendor 1, Document No.A1, Debit 1 000 LCY

Income Tax, Document No.A1, Debit 100 LCY

Vendor 2, Document No A1, Debit 4 000 LCY

Income Tax, Document No.A2 Debit 400 LCY

  • The only possibility to post this transaction is or to make the bank account as default balance account at batch configuration or to input manually per each line the bank account as a balance account

I want to post the bank account as a separate line for all transactions in the top for the reason that it allows me to reconcile and crosscheck that the totals of payment worth the singular payment.

When i try to post i get the error message that there are more than one vendor entry and it should be separated by a document entry (The lines are balanced by document no) or an empty line …

Can anyone help me on this ?


In a payment journal the system is expecting you to be paying a vendor from a bank account.

If you did exactly what you have described here as a general journal it would post ok.

But, looking at what you have put in the question, the document numbers do not balance as there are A1 and A2 entries, but i dont know if that was a typo or not.

Hi santuco,

you will always get this message as long as you’re posting with more than one vendor and/or customer and VAT in one transaction. Probably your income tax account has settings filled in for posting type, and at least one of the posting groups. Those will be copied into the payment journal line, resulting in the attempt to assign the VAT created out of the posting group data to one customer or vendor. If more than one exists, you will get the error message you mentioned.

hotfix: Clear the posting type and posting group fields in the income tax lines of your journal.

permanent fix: in the payment journal batch name, uncheck the “Copy VAT Setup to Jnl. Lines” flag - this will result in no VAT setups being copied from the G/L accounts. If you want to disable this for all payment journals, you can uncheck the same flag in the gen. journal template.

If you need the VAT posting (for whatever reason), the only way is to separate the transactions. This can be done by using the bank account as balancing account on every line or posting a balancing bank line per vendor. If you use the same document no. doesn’t matter, the system will use distinct transction nos. anyway. If you want to understand why NAV is doing this, I’d take a look into CU13.

with best regards