Test Data Transfer Tool with DB Cluster


I’m trying to export data from a Dynamics AX 2012 R2 production environment using the Testdata Transfer Tool.
The problem is, that when I run the export command

dp.exe EXPORT C:\TDTT20170329 Live2012R2 my-cluster/GM2

I get following error message:

A connection with the  Server=my-cluster/GM2 cannot be established. Please check the Server is accessible

Unhandled Exception: System.InvalidOperationException: ExecuteReader requires an open and available Connection. The connection's current state is closed.

The AX DB is hosted on a SQL cluster configuration where my-cluster is the cluster. The cluster has two server nodes: node-a and node-b.




The AX database Live2012R2 is running on node-a. However when we refer to the AX DB (for example from the Management Reporter) we use my-cluster\GM2 to address the server instance.

I have tried to execute the above dp.exe EXPORT command on node-a and on node-b using different variations for the last parameter

  • my-cluster/GM2 (executed on node a and node b)
  • node-a/GM2 (executed on node a)
  • node-b/GM2 (executed on node b)
  • IP-Address/GM2 (executed on node a and node b)

The error messages stays the same (except for the server name, which mirrors the last parameter).

Any help is appreciated.

May I know your DB Server Name ?

For reference, there are also replies in the duplicate thread on another forum.

Sure thing: It is my-cluster\GM2.
This information is retrieved by executing: SELECT @@SERVERNAME

Try to Install Test Data Transfer tool on DB server and execute your DP.exe command from Db server

It is installed on DB server

I read your duplicate thread, You should use my-cluster\GM2 rather than my-cluster**/**GM2

You can try like this dp.exe EXPORT C:\TDTT20170329 Live2012R2

Then you should have also read, that this will give just an “Unsupported character exception”, because backslash is not allowed in the parameter.

Also tried that. It will default to the localhost machine. Also gives the same error message. My guess (but just a guess), it needs to connect to the instance which is GM2. But how to point it to that instance is not clear to me.

In that case try to give only instance name like dp.exe EXPORT C:\TDTT20170329 Live2012R2 GM2.

Good thinking :slight_smile: Had the same idea. Unfortunately does not work either.

Here you go


Where clearly mentioned

Specify the computer name or instance name of the SQL Server computer that is hosting the Microsoft Dynamics AX database. To specify an instance name, enter it in the format ServerNameInstanceName. If you have a named instance on a local computer, you can use the format localhostInstanceName or InstanceName.

Yeah - I know. According to this documentation the following should work but does not.
dp.exe EXPORT “C:\TDTT20170329” Live2012R2 GM2

It gives following error (where it seems to be using the instance name as server-name, although the documentation says that just using the InstanceName would be ok)

A connection with the Server=GM2 cannot be established. Please check the Server is accessible

In addition the documentation cannot be correct. E.g. it says ServerNameInstanceName. There is no slash or other delimiter between ServerName and InstanceName. So how would DP.exe know which part is ther Server and which part is the Instance.

Did you try wrapping the server name in quotes

dp.exe EXPORT C:\TDTT20170329 Live2012R2 ‘my-cluster\GM2’
dp.exe EXPORT C:\TDTT20170329 Live2012R2 “my-cluster\GM2”

The below blog shows similar scenario is successful with Import command, however the command in screen shot looks different.

Also try just similar to screen shot in the above blog and see what you get
dp.exe EXPORT C:\TDTT20170329 Localhost\Live2012R2