TableData 1000000003 does not exist error message in restore

I am having an issue here.

Client is on NAV 5.0SP1, running with a SQL 2005 backend.

I take a full backup of objects and data through NAV.

On my computer I create a new SQL DB through NAV. I go to restore the backup, and it comes up with this error message

‘TableData 1000000003 does not exist’

I can’t figure out why this is happening, any ideas? Has anyone come across this??

Check the original NAV system where you got the backup from. And check if such kind of table exists or may be its only a view. You have to check and may be you will have to take backup again.

I have checked in the original NAV system and the table 1000000003 does not exist. I even wrote a report to show my all the tables (in case some were hidden) and it didn’t show up.

I can take the backup again, but when i go to restore it, the same error will show up.

Before taking backup compile all objects and look for similar kind of error in objects that have errors after compling, if the error exist fix there first and then take backup again.


Table Data 1000000003 does not exist means you have created a global or local variable with record Data Type.That variable pointing out the table ID 1000000003.But that table is missing in you Navision Object list.


Jerome Marshal.J

Is there a way to find out which global or local variable it is ?

So what you are saying it that another function in NAV is calling tabledata 1000000003, and that table doesn’t exist right ?

Complile the objects and you will know.

There is no specific way to find out this.

you should check global and local variables.First find out which object is gives this error and check all the variables which are defined in that object.

1.Compile all the objects. Now you can see which objects with error

2.Now compile the error objects individually now you know which object gives the particular error.

3.Now check the variables of that individual object

this is the way you have to find out.


Jerome Marshal.J

if found that variable remove it and compile.and start your work.

Go to the original Database, run Tools Restore, when you get the message, say DELETE EXISTING BACKUP. When this is done create a new backup and restore this.

The error is from you not completing an earlier restore. (This is assuming you are doing the second restore into a new database).

I tried going to the restore again. I have seen that message come up telling me to continue the restore in the past, so when you continue and finish the restore it removes the tables. That is what i thought happened this time, but when i tried the restore, that message didn’t come up. Strange.

But I have found the solution, I compiled all the objects in the object designer, and then did my backup and restore, and it worked !!! Strange, but I am good to go now !!! Thank you everyone for your input. I took the suggestion my IMRAN. Just compiled all the objects.

My gut feeling here is that when you went to the Restore, it some how deleted what ever tables were causign the problem, and made the new backup work.

Normally you can have totally messed up objects and they will still restore.

Anyway the good news is that your problem is solved.