TableData 1 does not exist

Hi everyone just to see if anyone of you have experienced something like this before and could give me any advice on how to solve it.

I’m using the Test database tool on NAV 5.0 SP1 client on the next menu path File - Database - Test, I’d been testing each of the options that this tool gives to me but I’m getting an error when I do the last of the customized options “Test field relationships between tables” and I’m getting the next error message “TableData 1 does not exist”.

I’d been searching with the Microsoft Dynamics Developer’s Toolkit but I can’t find any reference of that variable on any object of the db. I compiled the tables, forms, reports and codeunits using the F11 key and still not getting any error at all.

Do you know what can be happening and what can I do to eliminate this error message any help will be greatly appreciated.

Receive kind regards.

hi friend

there must be a filed in that field it has the relationship with one table . some how that table is not exsist in your DB any more

we have to find that field and delete the relation ship or you must define a record variable with out assigning the table



Are you working with a localised version of NAV, which edition?

Table #1 is not created in my local version.

Hi Jonathan!

I’m working with a localized Nav version 5.0 SP1, but I tried everything that already know about searching fields or variables into a NAV db and cannot find anythiing about this table, are you thinking on something?

Receive regards.

Hi Satheesh!

The thing here is that I cannot assign any record variable to that table 'cause it doesn’t exist anymore in the DB, I know that some field has to have a relationship with a field of this so called TableData 1, but I used the Microsoft Dynamics Developer’s Toolkit to try to find any Table Relation with the Source Finder tool of this application and still find nothing on this regard, do you have any other idea or shortcut to track this error without checking each and every field on the DB?

Thanks and receive many regards.

THis is not easy.

Bad news - The relationship could be in any object…

Good news - it should only be in a modified object?

Who or what is the source of the NAV database and object?

Do you have access to a W1 product, can you find the objects that have been modified in the your version?

Can you dump all objects into text = you have product specialist licence. Then you can load the object text file into a text editor and use FInd.

You should then find the text “Table1” in the file. Anyway there will be more than one reference for this.

Can you dump the part of the test log file which refers to this error? We should be able to identify the exact place of this error when seeing this part.