Table Relation Error

I have one table in which I have option string where in I have 4 different values now I am fetching these values to another table by creating same fields. The table relation is working for all 3 values but the last value keeps on giving me this error. I don’t know what I am missing here ? I have checked everything e.g. space or comma.

Microsoft Business Solutions-Navision

A ‘)’ is missing in TableRelation.

“Required-Approved Name”.Type WHERE (Type=CONST("Approver Department "))


Did you type that in there yourself? I always use the UI to build the relationship, and have never had any issues like that. It doesn’t look like that’s the entire tablerelationship. Have you tried sticking another ) in there?

No, I try to avoid that used the lookup to create this filter. Yeah I did try that as well means sticking another ) .

Though after fighting it for some time I created another field [:D] so it worked but still would like to know why I got it earlier, I just wanted to avoid creating another field.

if you don’t post the entire table relationship value, we will never know

Oops, I won’t be able to post this again as I said I created another field.

Then we’ll never know [Y]