Table doesnt exist

Hi Community,

I try to open two tables from a code:

SysTableBrowser sysTableBrowser = new SysTableBrowser();

I can open the purchParmLine table from there, but not the Table costControlTransCommitedCost.The error is “The table costControlTransCommitedCost doesnt exist”

I uncommented everything except those two methods and the mistake still occurs.

Does anyone know what is the problem? Hope for you help!

Should I perhaps look in some permissions that I am not aware of?

Thank all für your help.

I think object name you wrote is not right…; – wrong; – right

Hej Krishna,

thanks for the answer.

I tried this one CostControlTransCommittedCost and this one costControlTransCommittedCost - but the error message stays the same.

I mean the Table purchParmLine works either way…

I also declared my tables in the beginning as

CostControlTransCommittedCost costControlTransCommittedCost;


have you got answer? if its solved then mark it as verified solution…

Unfortunately the error message still appears

It is working fine in my environment. Are there any issues with the table? Have you tried synchronizing it?

Maybe you can debug the code where the error occurs for more information (set a breakpoint in class “Info” method “add()”)

What Krishna meant was that you missed the double t in your code. Your reply focused only on the first capital letter, so I’m not sure if you noticed the spelling error.

Don’t declare the table

Thank you, I checked that too, still no positive impact.

Does the table exists in the AOT/Data Dictionary/Tables note? If yes, then just Copy & Paste the name from there. If it doesn’t work please show us your entire code

Hi Jens,

your suggestion works - thank you! :slight_smile: