SysCompilerPutput error

Hi All,

Facing issue on save of any change in X++ Code.

On save of method or save of any change in X++ Code ( even addition of some space in existing code), getting error message in class " SysCompilerOutPut" at method “RemoveexistingCompileErrors”.

I tried to revert all changes since last successful compilation Changes but still getting error on save.

AX process gets hang and goes to debug mode at above mentioned method.

Finally, have to kill AX client from task manager.

AX version : AX 2012

\Classes\SysCompilerOutput\removeExistingCompileErrors seems to be having an issue.

Compile the \Classes\SysCompilerOutput class and then try to save/compile your changes.

Thanks for reply.

On compile of mentioned class , Getting same error like before save or compile of some x++ code.

Try to change Output to Message window, if it changes anything (Tools > Options > (tab) Development > (button) Compiler).

Also, it seems to me that the method won’t be called if you compile the whole AOT.

Compiler is behaving abruptly.

Getting below error on compilation of any method or class or table

Error executing code: object does not have method ‘startCompilation’.

Stack trace


If you have any customizations of SysCompilerOutput, remove them. Then start AX client with -startupcmd=kernelCompileAll parameter - it doesn’t use X++ classes, so the problem in SysCompilerOutput shouldn’t prevent it from doing its job.

Tried to start AX client with command Argument. However it is taking hours and hours. and even client didn’t started…

The full compilation usually takes several hours, that’s nothing to worry about.


Tired to compile my AX installation 2-3 times however It did n’t compile successfully.

Finally Installed fresh AX 2012.

After that I whenever I am trying to compile any class, table etc. getting error of infolog of

“%1 Contains Compilation error”.

Attached the screen layout.6518.Untitled.png

What exactly did you do? Are you saying that you installed a fresh standard AX and the compilation in the initialization checklist failed with the error above? That’s hard to believe.

If you did something else, well, I can’t comment it because I don’t know what it was.