Subform field is not editable, but why ?

I have a subform where only one column has the editable property set to true. All the others are set to be non-editable. The editable property for the form is set to true. The form InsertAllowed and DeleteAllowed properties are set to false, ModifyAllowed is set to true. If I run the subform from object designer I can assign values in the one editable column ok.

But (and here is the problem) if I run the mainform then all the fields on the subform are non-editable. The subform control (on the mainform) has the editable property set to true . All the fields on the subform sourcetable are set to be editable.

There is no code which might be setting the properties on the subform.

I have looked at this till my head hurts. Perhaps this is my fault for working on a Sunday. Is there some property which I am overlooking which could be causing this problem ?


The only one left would be if the Main Form is set to editable false. This is inherited by the sub form.

The editable property on the mainform is ‘Yes’, so I’m afraid that isnt the cause [:(]. Thanks for the suggestion though [:)].


Suggestion: export the main and the sub form as text and search for the text ‘editable’ to find a possible location for the change?
Other question: Could it be a permission setup problem somehow, using field permissions setup or someting like that? Native or SQL environment?

we probably need to see some of the code/design then.

Joerg, you are a star [*]. I exported the objects as text and found that the frame control on the mainform had the editable property set to ‘No’. Changed that and everything is now fine.

Thank you both for your support

Bob [:D]

Glad to see you got a resolution. Could you also set the topic as RESOLVED, and give it a star rating.


PS Resolved is a dropdown on the top right of this thread, stars are on the left.

you’re welcome. As David mentioned: please mark as resolved and rate the topic.