SSRS Report code deployment


I accessed client system.

We have SSRS code in DP class. I don’t have any deployment permissions to deploy the code.

I changed some script in DP class and compiled. But the changes are not impacting. (Commented display of few fields).

WIthout deleting the object I even tried reimporting object but it still did not work. (I cannot delete the object and import, Reason: It is not Dev or Test)

Can you please tell some idea regarding this. As I dont have deployment permissions, Will that also impact on classes too.

(I requested for deployment permissions and it will take some time.)


Is that a PROD system? They might not have the X++ source code license, so you cannot modify the classes.
You should be making modification in a non-production environment and move the changes to Production.…/hh292604.aspx - See this on how to deply customizations across environments.

Dear Kranthi, Hope you are doing well. Thanks for your reply. You are correct, I am working directly in production. We don’t have specific data where we are asked to modify some minor change in production But the situation is worse. Anyways I will try what you said. Currently they are working on giving deployment permissions. I will let you know the reason. Thank-you.

There will not be any special permission just to modify the classes.

Dear Kranthi, We observed the code changes are not reflecting on the report. Ran both with CIL and without CIL. Refreshed caches etc., but still same issue.
The only option it is worked is Rename XPPIL folder and restart AOS server. Immediately it reflected. Not sure about the cause of it but my work is done. Thank-you so much for the support.

Krishna, Clearing the XPPIL directory while AOS is down and restarting the AOS is part of build & deployment process, which then updates the XPPIL directory with the fresh content.
In a fast paced development Developers try to get away from this step and find it hard caught up sometimes in a situation like this.
But you learned the steps to deal with it.

You should try to restart SSRS service

Thanks Kornerup. I will try with that next time.

Nice blog from you.

Thanks for the compliment Krishna.