SSAS Prerequisite Validation warning Dynamics AX 2012 R2

I am using AX 2012 R2 and SQL 2012 BI Edition and am trying to install SSAS extension for dynamics. I followed the official Microsoft installation guide pdf for the installation and while running the prerequisite validation for Analysis Services Configuration, I was caught up with this:

3823.prerequisite validation for SSAS.jpg

to try to solve the problem I checked the warning link and got this

0334.prerequisite validation for SSAS2(Compressed).jpg

then I browsed to the link and downloaded the cumulative update package 1 that was required for 64bit OS. When I tried installing the update I got this:

3005.prerequisite validation for SSAS3(compressed).jpg

the update could not pass this stage as nothing was enabled on this page. It stated that a higher update was already available and that the update I am putting up is a lower one.

This is the exact words:

A SQL Server update with a higher version has already been installed on SQL Server instance MSSQLSERVER, so the current SQL Server update cannot be applied. The version of the SQL Server update that is already installed is GDR 11.0.2218.0(11.0.2375.0) with a KBKB2716442 and the current SQL Server update is 11.0.2316.0 with a KBKB2679368.

Yet the warning still persisted.

Please how can I solve this problem as soon as possible.

Thanks.