Sharepoint setup error

Hi,

I am setting up the sharepoint but it shows this error that prevent me to setup.

Anyone have idea, what is going on? I can’t proceed my EP (Enterprise Portal) if sharepoint couldn’t be setup.

6404.Untitled.png

What’s going on is that SQL Server can’t start by some reason, but the message itself is not enough for saying why. Event log could contain more details.

Hi Martin,

Thanks for your help, gracias. This has been stuck me quite some times.

I tried another way to install the sharepoint, end up it shows this error.

Below link is the log file generated from the error above.

Your help is highly appreciate.

References Event Logs for above errors:

if above picture is not clear you may download from below link:

  1. https://www.hightail.com/download/bWJvT2pMTEREbUpwdmNUQw

  2. https://www.hightail.com/download/bWJvT2pMTER3TGpFdzhUQw

  3. https://www.hightail.com/download/bWJvT2pMTERxRTFqQThUQw

Thanks

Best Regards

hi Qiwei chen

pls chk the below link

http://muhammadkazim.wordpress.com/tag/an-exception-of-type-system-data-sqlclient-sqlexception-was-thrown-additional-exception-information-could-not-find-stored-procedure-sp_dboption/

Thanks friends, I solved it by installing sharepoint foundation 2010, sharepointfoundation2010sp1-kb2460058-x64-fullfile-en-us.exe.

But another problems exists when I install the Enterprise portal.

this is the error in the logs.

SharePoint is not installed on this computer. Install Windows SharePoint Services version 3.0 or Microsoft Office SharePoint Server 2007 before continuing.
Exception: Microsoft.Dynamics.Framework.Deployment.Portal.EPDeploymentException

Message: SharePoint is not installed on this computer. Install Windows SharePoint Services version 3.0 or Microsoft Office SharePoint Server 2007 before continuing.

FullText: Microsoft.Dynamics.Framework.Deployment.Portal.EPDeploymentException: SharePoint is not installed on this computer. Install Windows SharePoint Services version 3.0 or Microsoft Office SharePoint Server 2007 before continuing.
at Microsoft.Dynamics.Framework.Deployment.Portal.EPDeployment.EnsureSharepointIsInstalled()
at Microsoft.Dynamics.Framework.Deployment.Portal.EPDeployment.Microsoft.Dynamics.Framework.Deployment.Portal.IEPDeployment.GetVirtualServerList()
at Microsoft.Dynamics.Setup.DeploymentPortalWrapper.GetVirtualServerList()
at Microsoft.Dynamics.Setup.MainForm.s300_ShowTab(Object sender, EventArgs e)
at Microsoft.Dynamics.Setup.AxTabPage.ShowPage()
at Microsoft.Dynamics.Setup.MainForm.ShowPage(PageIDs pageID)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.PerformClick()
at System.Windows.Forms.Form.ProcessDialogKey(Keys keyData)
at System.Windows.Forms.Control.PreProcessMessage(Message& msg)
at System.Windows.Forms.Control.PreProcessControlMessageInternal(Control target, Message& msg)
at System.Windows.Forms.Application.ThreadContext.PreTranslateMessage(MSG& msg)

==== Setup encountered an unhandled exception and could not be completed. For details see the previous messages in the log. ===

What’s your version of AX? AX2009 doesn’t support SharePoint 2010 out of the box, a hotfix is needed. See Compatibility Result for Microsoft SharePoint 2010 for details.

Hi All,

Just to inform, my installation for enterprise portal has done successfully. Thanks so much for the help.

End up I reinstall the IIS in start > Administrative tools > Server manager > Roles > Web Server > Right click and remove roles

After removed, reinstall again by right click and add roles > Tick Web server to install it.

Just wanted share, in case may help on other people in the world. :slight_smile: