Does anyone know if you can use <> and * in a SETFILTER? I tried using the following: rSalEntry.SETFILTER(“No.”, ‘<>%1’, ‘EXP*’); It doesn’t seem to be working. Thanks!

I too tried to use this method, thinking it would be easier to write where Field1 <> String, but to my surprise, I was advised that this could not be done and that I would have to write what Field 1 was equal to. Is this the case ?

Try setting the filters manually on a table/form and see the results.

rSalEntry.SETFILTER("No.", '<>%1', 'EXP');

works fine, but if you use a filterstring with an asterix in ‘*’ it doesn’t work with ‘<>’. Soren Nielsen, moderator Integration/Developer NOLUG

rSalEntry.SETFILTER(“No.”, ‘<>%1’, ‘EXP’); will show other things such as EXPENSES that you do not want to show. an option would be rSalEntry.SETFILTER(“No.”, ‘<%1|>=%2’ , ‘EXP’,‘EXQ’); there must be a beter way though. Paul Baxter

Another solution could be to Mark alle records SalEntry.SETFILTER(“No.”, ‘EXP*’); Find all records and remove the mark SalEntry.SETRANGE(“No.”); SalEntry.MARKEDONLY(TRUE);

Keep it simple and stupid:

rSalEntry.SETFILTER("No.", '%1..%2|%3..%4','A','EXOZZZZZ','EXQ'..'ZZZZZ');

------- With best regards from Switzerland Marcus Fabian Edited by - fabian on 2001 Jun 15 00:39:42

Yes marcus But your method does not catch nulls or EXOZZZZZZZ so does not solve the origonal problem. Paul Baxter

Ok the Correct answer is rSalEntry.SETFILTER(“No.”, ‘<%1|>%1’ , ‘EXP’); Paul Baxter

Forget what I just said the only real answer that works was my first one. I no longer seem able to edit or delete my postings?