Service Item cannot be modified in this form

Hi there!

I have a small problem. On a new Form I have one Tablebox and one textbox.

The form has Source table = “Service Item”. The Textbox is for filter records shown i the tablebox.

Initially the tablebox shows all records from “Service Item”.

I filter the “Service Item” after every input in the textbox.

As I type something the Tablebox show 10 rows. After more typing it perhaps shows 2 rows.

Everything works fine but when i click in the tablebox a got the message: “Service Item cannot be modified in this form”

Can anyone help me?

Regards Håkan

Hi Håkan,

Well it’s not quite clear to me what you are trying to do. Could you make a screen dump showing the form?

i think here service item what you are using here is getting the values from master . in master we can not enter new values directly. if you want to enter new values you have to enter that values in the master form only but not in the form where you are using this master.

Hi Erik.

I dont know how to paste a screen dump to this text. I will try to be a little more clear.

“My TextBox Caption” _____________ ← Here I write some text who become the filter for the table “Service Item” and is shown in the TableBox below


The function with the fikter works ok.

I write some text inte the Textbox, Press Enter, and the filtered records is showned.

But when I Click in the TableBox to perform some more action I got the message:Service Item cannot be modified in this form"


i am facing the same problem,

we don’t need to add new value in the tablebox , just once we click in the tablebox the error occur

Have u check form properties ‘ModifyAllowed’ ?

Is there any customization ?

i set the ModifyAllowed = No and i still got the error

what you mean in customization?

Check Table Permission

Do you have any code in Form - OnAfterGetRecord() or Form - OnAfterGetCurrRecord() triggers?

Like CurrForm.UPDATE?

There are no code under these 2 triggers mohana , my only code is on init and open form trigger and onaftervalidate Textbox Grade.

if i choose a grade and i click inside the tablebox i have the below error

5123.test.bmp (526 KB)

one more thing,the table refrence to the form its a linkedobject (view )

can you be more clear what does it mean/

can you show us the code?

and properties set on form? (1.68 MB) (311 KB)

Set Table Bob Editable property to No.

it’s set it already to NO but i still have the same error[:(]

I tried with below code and working fine

IF FilterbyGenProd <> ‘’ THEN BEGIN
SETRANGE(“Gen. Prod. Posting Group”,FilterbyGenProd);
MESSAGE(‘No records’);
FilterbyGenProd := ‘’;
CurrForm.UPDATE(FALSE); // Add this line and try