Running two Dynamics NAV 2018 and 2017

I have two NAVs 2018 and 2017, I stopped server instance of 2018 to start NAV 2017 but its display error message from Dynamic NAV 2017 Administration.CaptureNav2017.PNG

Please how can i solve this, thanks

Well the message is pretty clear.

You need the NAV 2018 version of the administration to administer NAV 2018 and the NAV 2017 Administration to administer NAV 2017.

Yes, I used NAV 2017 Administration to administer NAV 2017.

Erik is right… Seeing the error you have tried to start a NAV 2017 service with NAV 2018 Administration.

The message said that you were using the NAV 2018 (11.0) to stop a NAV 2017 (10.0) service.

If you just need to stop the service, then you can use Windows Services.

If this is a test server, then you could either use different ports (instead of 7046…7048) or just configure it to allow TCP portsharing. That would allow you to have both NAV 2017 and 2018 running at the same time.

I was in NAV 2017 administration while starting it, displayed error message. After i have stop server instance of 2018 in NAV 2018 Administration.

I used Windows Services, it was running (Server Instance for 2017) but displayed another error message while connecting to Role tailor CenterCaptureClient.PNG

You have to Read the box it says that you are trying to do a login to af NAV Servicetier which is running one version and with a client that runs another version!

SO You are having 2 servicetiers running on the same portnumbers.

NAV 2017 and NAV 2018 run on the same port but I have stopped NAV 2018 (ServerInstance) while running NAV2017 it displayed the error message above

The message say that you want to open the NAV 2018 client, and since you have stopped the NAV 2018 server then it fails.


You are clearly missing som very important details about NAV, and you have to bring on some detalis about your installation. For some reason you don’t understand the answers that we are trying to give to you. Have you read the Installation and Configuration guides on NAV???

The default portnumbers for NAV 2017 are 7045-7048 and the default servicetiername is DynamicsNAV100

The default portnumbers for NAV 2018 are 7045-7049 and the default servicetiername is DynamicsNAV110

SO…you have problem with one or more of these ports/names.

You can try to fix it manually.

EDIT the file C:\Program Files\Microsoft Dynamics NAV\100\Service\CustomsSetttings.Config and verify that it matches the above name and portnumbers


EDIT the file C:\Program Files\Microsoft Dynamics NAV\110\Service\CustomsSetttings.Config and verify that it matches the above name and CHANGE the portnumbers to 7145-7149 (it is possible to use the same port - but then you have to do some other changes first - now it is a matter og making sure that it works).

Then run SERViCES.MSC and start the two services. IF they don’t start then something is still wrong with your settingsfile.

Start your NAV 2017 CLIENT, and try to connect to localhost:7046/DynamicsNAV100 for NAV 2017 and then try
NAV 2018 Client with localhost:7146/DynamicsNAV110

If no luck… read the evenlog on the servicetier machine.

This is basic setup issues and you should really know about stuff like this before you start destroying installations :slight_smile:

When everything works THEN you could download the Service Tier Administration Tool found here:

But it won’t do you any good unless you can start the two versions with no errors.

I installed NAV 2108 as Demo. It try your method but stil with the same error

My thinking of uninstall NAV 2018 or what do you think

I guess it won’t help, because if you just did a NAV install 2018 then it might have destroyed your 2017 installation. But its hard to say because you did not provide much information about your setup.

If it is only for testing you should instead use Docker as it easier, faster and a sure-thing every time.

And the Evenlog should tell you some information about what went wrong.

I you want to get it fixed, bring on more information.

From the uploaded sent, I started NAV 2018 Role Center After I started Server Instance 2017 from Local Server (Window)

The message clearly says Client is NAV 2018 and Server is NAV 2017 so the problem is entirely because you do something wrong. Are the two service tiers running in SERVICES ??? Any messages in the evenlog/eventviewer?

Again, in order to get the proper help, you need to bring on more information about your setup.

I had from a NAV Senior Developer, that I can’t start NAV 2017 Server Instance from NAV 2017 Administration Console Because NAV 2018 has override it. I changed the port number as you said early. And started from local service and run NAV 2017 Role Center. It was working fine. Thanks, am gratefully

Great !!! use the Service Tier Administration Tool (Link Below) it removes the need of the NAV 2017/NAV 2018 Administration tool.