Running a report in RTC Client

Hi everyone,

I have a report designed to work in both Classic and RTC Client.

But everytime I run it, I get the Classic report displayed…

What shall I do to get the RTC report when I need it???Is there any property that I need to set up???

From where are you running the RTC report?

Do you have rdlc data for report?

Yes, I created a layout suggestion and saved it…

I am running it using the command line:


I get the following error message:

Object of type report with id=50000 could not be found

How many NAV versions/instances are installed in your system?

Sounds like multiple systems/versions installed. Make sure these do not use the same port, or use port sharing.

But since you say it worked originally, just without the RTC report layout. Then I don’t really think that this is the case.

You can also insert the report into the department menu of the database you are changing it in. If it’s not added to your menu, then you have the wrong report.

When adding it to the menu, it worked [:)]

but I still not understand why it doesn’t work when I run it from the prompt command…

About multiple systems, I only have NAV 2009 R2 installed, nothing else …

I recompiled all the objects, it works fine now…