Role center Page is always empty for my account(White Page).

I tried to copy the customization which my work colleague made in his RTC client for a certain role center page into my Metadata table. I did as fallow i copied the Metadata row for his account (which is only related to this certain page) and I created a new line in the Metadata table with my user name.

Since I made this each time I start the RTC the role center page is always empty for my account! I even tried to delete the Metadata line related to this Page (for my user account) but nothing changed. I also restarted the server and still the Role center page is empty only for my user.

How can I fix this issue? I just want to be able to see the role center page again when I open my RTC client.

did you change the SID in the copied row?

is there a row with your SID in table user metadata, maybe with empty values ?

Hi Jonatha,

Yes I changed the SID, but still no changes. I even deleted the line and till now my page is empty. I re-imported the object and no changes. If any one of my colleagues try to open the RTC (They have the same Profile ID as I) they get the role center page normally.

After trying many times I made it :slight_smile: !

Instead of deleting the whole line with my SID ID, I set the User ID to ’ ’ and the Personalization ID to ’ '. This will make this SIDE point to other object and it solved the problem.



Hi Mohamed. Can you help me? we have same issue for several rol centers, in blank, no ribbon too.
I tried your suggestion but no worked for me, user ID cannot be blank in my case.
Thanks in advance.