Report won't open in Object Designer

In the midst of putting together a report in NAV (v4.0 SP3), something happened that prevents the report from being loaded into the Object Designer. I had just entered a lengthy text string into the SourceExpr of a textbox, compiled and tested the report, then went back to open it for more modification. Instead of seeing the Report Designer window, I’m presented with the message “Microsoft Business Solutions-Navision has encountered a problem and needs to close. We are sorry for the inconvenience.”, and a choice of whether or not I want to send an error report to MS, which I did. I’ve tried several times to open this report, all with the same result. The ‘broken’ report runs, albeit with only part of the text I entered, and other reports still open in the designer.

Is there some way to find out and repair what’s causing the Designer to choke?


See if you can export it to text and remove the code from there.

Thanks for the suggestion, Matt. Unfortunately, I’m not allowed to export to text. I did try exporting to FOB, then importing back, but that didn’t help.

Do you have a backup that you can get the report from before this modification?

If so export & import that old one. If it opens then you know for a fact your mod is the problem.

Then redo your mods in the ld one but becareful about this long text you added.