Renamed user doesn't work as expected

Hi all,

We are encountering an issue for which I haven’t been able to find any solution online. I will try to give you as many details as possible.

  • system version: NAV 2009 R2

  • User accesses NAV only for Vendor Approvals

  • User got created in both SQL and Active Directory with an extra -r in their name (misspelled)

  • When the mistake was rectified, the user and login have been renamed

  • User was able to open NAV but would see 0 Vendor Approval’s. When clicking on the task, it takes her to the Vendor Approval list but the filter is her misspelled previous username. She can remove the faulty -r at the end, but when she tries to approve the system is saying she doesn’t have permissions to do so although it shows her as being logged in with the correct name

  • Both login and user have been deleted and recreated but to no avail

  • The only solution that works is to remove user from Windows Logins → Synchronize all users → Add user again in Windows Logins → Synchronize all users (this action has to be performed every morning, because somehow her old user comes back to life during the night…)

Did you ever encounter something like this? Do you have any ideas how it could be fixed?



Have you checked what username sits in the Approval Setup? Maybe still the old one…

No, the approval fields contain the correct username.

I have found her old username in User Menu Level and deleted it. The next day the old username didn’t come up. The day after it came up again. Today it worked again properly. Hoping tomorrow will stay as is without the old username poking its head again.

It’s just so difficult finding the root cause!

Thanks anyway,


The problem may lie in the fact that Windows itself always uses SID (hence you can edit Win user name as you wish), not user name when security is concerned, but NAV… sometimes (log-on) uses SID, sometimes ID, sometimes user name.

For approvals, NAV uses Approver ID, which you can check in Approval User Setup. Therefore, user name in all it’s various incarnations shouldn’t make any difference…

I have checked the table and it contains the correct approver ID. All the tables seem to contain the correct ID which makes it so frustrating.

This seems to happen a bit randomly so from your post and the way we use the system I brought down the possible causes to 2:

  1. It might have to do with user synchronizing (because after I delete her and add her back I need to “Synchronize all logins” otherwise it won’t work)

  2. NAV picks up the wrong SID/ID/username in some days, but wonder if there’s a way to check which one it’s using in like a log or something?

Any ideas re the above? Could one of them be the cause?

Hello Lia,
have you solved you Problem?
I have the same Problem after rename the user…

Best regards,