Refund option missing from OptionString - Possible BUG?

Hi there,

I encountered a problem with “Cr. Memos for Advance Invoice” on Croatian/Serbian localization of NAV 5.0 SP1.

When I post the Cr. Memo for Advance Invoice which has the “Applies-to Doc. Type” field set to “Advance Invoice” (“Applies-to Doc. No.” is also set to appropriate advance invoice no.) it ends up in Posted Credit Memos with “Corr. Advance Invoice” value in the “Applies-to Doc. Type” field (“Applies-to Doc. No.” field is unchanged and still points to the correct invoice).

I looked at the OptionStrings of the “Applies-to Doc. Type” fields in the “Purchase Header” table and “Purch. Cr. Memo Hdr.” table and found this:

Code:
Purchase Header:
,Payment,Invoice,Credit Memo,Finance Charge Memo,Reminder,Refund,Advance,Corr. Advance,Advance Invoice,Corr. Advance Invoice

Purch. Cr. Memo Hdr.:
,Payment,Invoice,Credit Memo,Finance Charge Memo,Reminder,Advance,Corr. Advance,Advance Invoice,Corr. Advance Invoice

The Refund option is missing from “Purch. Cr. Memo Hdr.” table. Value in the database is the same (9) but the OptionString is obviously causing the problem with the NAV representation of the value.
Is there anyone else who can confirm this behavior?

I checked the W1 database of NAV 5.0 SP1 and everything seams to be OK there. OptionStrings are identical and include Refund option.
I wanted to add the missing option but decided to consult the community and see if anyone did it already and if there were any known problems after that.

Thanks,

Anil

My guess is that you’re right. It sure looks like a bug. So you should report it to Microsoft.