Reference to the member Posting of the variable could not be solved.


In the form when i am trying to post service order and sale order, i am facing error which is “Reference to the member Posting of the variable could not be solved.” i found solution on web but could not understand what is the exact solution of this i face this errror many time when i call any codeunit in form or report this type of error comes so now in form i comment the codeunit calling code after this still am facing the same error . please share your feedback [8-)]

Using 2009 R2

Thanks in advance.

Have you done any customization or removed any customization ?

yeah i am working on sms system in navision so i have created some table,form and codeunit and now as i am calling this codeunit in form and run then in posting i am facing this error.

Hi Sachin,

You mentioned that you found a solution on the web that you didn’t understand. Could you post the url here so we can see what you’re talking about?

In the meantime, take a look at your code to find the line that’s raising the error (use debugger if need be). If the line includes a reference to a record variable to which you’ve added a field called Posting, then confirm that the record definition in that database actually includes the field definition. If that’s not the issue, maybe you can post a bit of the code that raises the error?

Hi Sachin,

I think you changed the field ID of Posting field in Navision.

Use the debugger and the line where debugger shows error, just remove Tablerec.Posting in that line and write again using C/AL symbol menu(F5) because I think you created a new field “Posting” in any table with some ID(say 50000), wrote the code and changed the field ID again ( say 50001). That’s why System shows error. System taking the reference of previous Field ID(50000). If multiple lines contains the “Posting” field, then re-write all Tablerec.Posting again using F5.

This should resolve your problem.



hi george and bheem

thanks for the reply

as us said i did not add any field related to posting i just add some field in table which relates to sms functionality and in form and now i am calling in the service order and sales order form after that now i removed that code from the service order form and am still facing this error.

so i want to tell you that i did not do any thing related to posting functionality.could not understand what’s happening this.

Can you show the line where debugger throws error ?

My feelings is that you should try compiling all objects first…