Query Object Not initialized when clicking Closing balance in Trail balance

Hi All,

I’m receiving the below error message when i click amount fields in trial balance form after GST upgrade in AX2012R2.

QueryBuildRange object not initialized.

Stack trace

(C)\Forms\LedgerTransAccount\Methods\init - line 234
(C)\Classes\SysSetupFormRun\init - line 3
(C)\Forms\LedgerTrialBalanceListPage\Designs\DesignList\EndingBalance\Methods\jumpRef - line 10

I tried compiling all the above objects. Also done full compilation, Full CIl and DB Sync. also tried deleting Xppl folder also. nothing helped.

any suggestion please.

It doesn’t look like a compile/CIL issue. Have you tried to debug and see why that object is not initialized?

Have you tried clearing your usage data and AUC files, sometimes when installing updates if the cache has the old version of an object it can cause errors like that, but it also could be something else…

AX Version : AX 2012 R2 CU6

Below is the code of init method of LedgerTransAccount Form :

I put debugger and found that in line number 232 (in above screen shot) , “ds” is getting Null value. I don’t know why?

I checked with other customer with same AX version working fine.

Please suggest.

Have you also tried what Manuel suggested(clearing usage data)?

Yes, Deleted AUC files of all uses and restarted the AOS . Still error occurs.

Did you see LedgerTransAccountTmp in the form data sources?


Do you have any changes on that form? (ISV/CUS/USR)
If so compare and check if the SYS/SYP code is properly merged…

Below is the data sources in LedgerTransAccount Form :


I have changed the Link type property of LedgerTransAccountTmp data source from “Passive” to “ExistJoin”,


then form gets open when i click amount field in Trial balance form, but Empty Form no values showing in that form.

I have done Rebuild balances also.

Why it was set to Passive initially ? I can see in standard that the link type is set to ExistsJoin.
Have you done the compare? Also compare the init method of the form and see if some standard code is missing.