Purchase requisition is not getting converted automatically

Hi,

In AX 2012, all my PR are getting converted to PO automatically. Those PR which got converted has the status as CLOSED.

This is fine.

Only one specific PR, which has completed the workflow approval cycle; showas the status as ‘Approved’ and doesn’t get converted to PO.

Any idea?

regards

TP

does all the PRlines have the “Vendor Account” attached to them?

Yes

I guess it could be because of two reasons:

1)may be your PR might have been created, before you have enabled the “Automatic PO creation” setup.

  1. run automatic Purchase order creation as a batch job is checked?

Hi,

thanks for your reply.

Regarding the point No. 1 this is not applicable. Even I looked in RELEASE APPROVED PURCHASE REQUISITION, this PR is not dispalyed there.

Point No. 2, can you please tell me where i can check this. In fact all other PR is getting converted automatically to PO no issues at all. Only this particular PR got stuck

regards

Thomas

Thomas, the above comment reminded me some other issue which i faced. I think the green color flag against the PR is missing that could be the reason. Please confirm

The flag that i’m referring to is “PR List page> left side to the PR number”

couldn’t post the image as some problem with site.

Hi,

Yes you are absolutely right the GREEN FLAG is missing on the PR lines

regards

Thomas

It is identified that if that flag appears then only it comes into your “Release approved PRs” form.

With help of my techie friend, we found that the corresponding "source document " has incorrect status. if we change status, then you will see the flag. But, we didn’t research on why that status is different and what will be the implications.

Tables>Purchreqline > select the record>copy the value in “source document line” field

tables>source document line> select specific source document line and change the status to “completed”

This is just to help you to investigate further, try in test environment.

I am having the same problem too today. Same situation, Approved PRs that never close and do not even appear in the PRs the released approved PRs list.

Here is what I have checked thus far:

· PR does have a Vendor

· Checked to see if change management is activated

· I have the purchasing policy to automatically create a PO activated

· Checked to make sure I have a procurement internal control purpose assigned to a hierarchy (just like contoso)

· I have even run the periodic “Batch purchase order generation” as an extra process

Resolved…the default blank batch server was not assigned. I just assumed it was something I did when tinkering with the workflow, when in actuality it never worked because it was never set properly after the last copy in the test env I was working in.

This article helped me identify the issue.

https://community.dynamics.com/ax/f/33/t/78293.aspx#.Uae6PZyKySp

Changing the field’s status in Table could be technically correct but MS has provided the workaround for this problem.

Just select your PR and on the Financial tab click button Reserve budget funds. This should bring your PR to Release approve PRs form to further process.

Hi kiran,

You are right, if we click “Reserve budget funds” button then status will change but in my case i’m using the workflow, and i don’t want to click this button manually.

Do you have any idea how to automatic reserve the fund???

Let me know.

Thanks Kiran. Worked a treat !!!